HFS+ disappeared in WD Mybook 3Tb

Using TestDisk to repair the filesystem
Post Reply
Message
Author
emilio3D
Posts: 2
Joined: 24 Oct 2013, 17:42

HFS+ disappeared in WD Mybook 3Tb

#1 Post by emilio3D » 24 Oct 2013, 18:17

Hello,

I'm Emilio, i'm new to this forum and majorly to Testdisk to. I've been researching since yesterday so i'm still learning about what it can do for me.

So recently I had my WD My Book 3Tb external drive, HFS+ formatted running on Mac Pro, and left it through night exporting a task in Final Cut Pro through Compressor (actually this drive only had the files, the task was being written to another drive).

So in the morning I came up to see it crashed, restarted and no sign of this drive. First I've tried switching to new disk enclosure of WD too, read somewhere it could work, but it didn't solve anything.

In Disk Utility (like in Disk Management in Windows that I tried after) the drive appears but not in it's given name (only gives the "machine's" name - 3TB WD My Book 1170 Media), and doesn't show format type or partition map scheme.

Disk only has one partition in HFS+ besides the EFI System.

So researching i came up to TestDisk, learned about some of the features and using it but i'm not sure how can he help me now. It reads both EFI System and Mac HFS Partition. I've tried running pdisk on mac Terminal but haven't succeded right on the begining, it promptly retrives an error "Floating Point Exception", error which I couldn't found info about why it shows.

So before making something wrong, i sticked to TestDisk, but i'm not sure where to go from now to repair and make it operational, so I came here for help.

I think this might be easy to recover but not sure what to do, back it up in image disc first? The files are really important, it's a working disk that we can't afford to lose right now... It's not that old too, 6months max.

Thank you in advance, i've tried to know the most before coming here, but i'm new to recovering discs.

I'm leaving it analysing through the night. Here's an image of what it's detected.
Attachments
testdisk1.jpg
testdisk1.jpg (88.89 KiB) Viewed 1850 times

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: HFS+ disappeared in WD Mybook 3Tb

#2 Post by Fiona » 25 Oct 2013, 18:11

Data on some WD disks are hardware encrypted.
As long you shouldn't change your enclosure!
http://forum.cgsecurity.org/phpBB3/post ... disk#p6552
TestDisk get its info from the OS.
Only the DOS - version gets the info from BIOS.
That's why its recommended to make a diagnose on an Intel-Mac.
You should avoid to use pdisk, because it's only supported by the old PowerPC, not Intel Mac.
Some information here;
http://www.cgsecurity.org/wiki/OS_Notes ... 28Intel.29

Fiona

emilio3D
Posts: 2
Joined: 24 Oct 2013, 17:42

Re: HFS+ disappeared in WD Mybook 3Tb

#3 Post by emilio3D » 08 Nov 2013, 21:26

Hello

Fiona thanks for your help.

I read somewhere that many problems with WD's are just some kind of trouble with that exact hardware part that encrypts the files, and switching by a similar could resolve it, but it didn't..

I'm led to believe that the problem might haven't been that critical as I thought, but still many files were damaged, i think maybe 25% of the disk's files.

I have created an image disk with Testdisk to another 3TB drive (almost two days to make it), in the end it said it hadn't further disk space to continue the Image Disk file. I still took a try with OSFmount and voilá, i made it to the files on the damaged drive. Backed'em up and almost happy end of story.

Not convinced yet, I cycled through some more inputs about WD external drives, and I found some guy who had kind of similar problem, just couldn't mount the drive. Amazingly, just by using a s*** usb extension cable made him gain access to the drive. I tried it with the damaged drive and.... it mounted in Windows. Just did it on the first time I tried, since then it has never mounted again even with the extension. It was that only time that i managed to check the files and be sure they were really corrupted (thought it could be a problem with the disk image).

So it's kind of an end, learned a lot with this, specially avoiding WD external drives probably...

Still don't know if I handled the process correctly with Testdisk, but it kinda worked out! I did it only in Windows, do you think I might not get corrupted files if i make full proccess again on Mac with Testdisk? This Mac was good in his new days, but to run this 3TB process it would be a long painful waitl, as it still got me many days to work it out in my Windows, which is recent and reasonly powerful :P

Thanks for the help, also here i'll be to share my experience if anyone needs!

Hecht
Posts: 2
Joined: 22 Nov 2013, 03:25

Re: HFS+ disappeared in WD Mybook 3Tb

#4 Post by Hecht » 22 Nov 2013, 13:43

Perhaps.. this is the hottest issue from the Apple and WD Support Communities?

Mavericks-Upgrading corrupts external hard drive:

https://discussions.apple.com/message/23493143#23493143

http://community.wd.com/t5/External-Dri ... d-p/613775

http://community.wd.com/t5/External-Dri ... d-p/602387


Which OS-version you have installed now?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests