Write Protected

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
aliusman227
Posts: 1
Joined: 03 Dec 2013, 10:14

Write Protected

#1 Post by aliusman227 » 03 Dec 2013, 10:26

Hi
Due to files un-deletable (when i click on any file there was no option of delete). i decided to format it, formating 100% and message appeared can't format media is write protected. i tried every method to remove read only by searching from internet and many softwares but no solution. even hex editors say can't write disk is write protected.Then during my search i find test disk. there were partitions with HFS format but it also say write protected. is there any solution???
kindly share with me how to remove write protection. CMD failed, Partitionguru failed, Active kill disk failed and many more failed to remove write protection.
Reply me must
Regards
Ali Usman
aliusman4201@gmail.com

Sponsored links

funkazio
Posts: 3
Joined: 11 Feb 2018, 09:47

Re: Write Protected

#2 Post by funkazio » 11 Feb 2018, 10:11

I seem to have exactly the same situation on a few SD cards. Did you ever found a solution?

MarkSanders
Posts: 1
Joined: 02 Mar 2018, 19:36

Re: Write Protected

#3 Post by MarkSanders » 03 Mar 2018, 19:50

I have two USB flash drives that I am having a write protection problem. One is Sandisk 32GB and one is a PNY 128GB. Both were working fine with large files but then they were set to be write protected. I obtained all the data off of the drives, but I hate to loose the hardware....

I have tried regedit, dos partition readonly removal, various programs including TestDisk. But I cannot get through the write protection and reformate the drives. I would be glad to pay for a program that I knew would work, but I can't blindly buy an application and not get results.

Any thoughts or suggestions?

THanks,
Mark

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests