exfat partition corrupted then lost

Using PhotoRec to recover lost data
Post Reply
Message
Author
bobMuk
Posts: 2
Joined: 02 Dec 2013, 20:11

exfat partition corrupted then lost

#1 Post by bobMuk » 03 Dec 2013, 15:15

I had a 6bGB sd card in my Android phone, and upgraded from Samsung firmware to Cyanogenmod. Seems there's a known issue where a card moving from Samsung to any other Android version will get corrupted as Samsung use exfat and other versions just corrupt it... To make matters worse, while trying out the memory card in different card readers after it stopped working something's obviously written to it and I've gone from having a corrupt filesystem to broken partitions.

So I'm currently in a state where I did have a 64GB exfat partition, but now the card seems to have a 27GB raw partition on it. I've performed a standard and deep scan with testdisk and haven't found any recoverable partitions.

I've also tried photorec and have recovered some of my photos, but it looks like photorec's only been able to look at that first 27GB and not the space that follows it.

I'm not sure what'd be the best next step - delete the partition and create a new one (quick format) that covers the full 64GB? I'm assuming if I jsut delete the partition and don't create a new one then Windows won't even see a drive letter and I won't be able to scan it at all?

Any help or advice would be apreciated!

Sponsored links

bobMuk
Posts: 2
Joined: 02 Dec 2013, 20:11

SOLVED: can only see the first 27GB of 64GB card

#2 Post by bobMuk » 04 Dec 2013, 13:03

Solved!

I used USB Image Tool http://www.alexpage.de/usb-image-tool/
...to clear out the boot sector on the card. Seems corrupt data here can make Windows/Linux beleive the card is smaller than it actually is. USB image tool has a "reset" button which simply clears the 512B in the bootsector and suddenly I can see the whole card.

After that photorec found what I think is all of my missing photos! Phew - that was photos covering a year of my kids' life I've got back.

Huge thanks to Christophe - I'll be making a Paypal donation shortly! :)

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests