Command not found-Linux Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 4
Joined: 20 Dec 2013, 15:53

Command not found-Linux

#1 Post by Stuartf »

Running Mint 15, this is all new to me. Need to find some photos, so downloaded version 6.13 from Software Manager.

I go to terminal and type "sudo testdisk-6.13/photorec_static" and get message:
sudo: testdisk-6.13/photorec_static: command not found

I checked in software manager and it said I had version 6.13-1ubuntu2
so I tried "sudo testdisk-6.13-1ubuntu2/photorec_static" to no better result.

Any guidance, I deleted a couple of year's photos from Picasa as it showed duplicate directories, but I guess that was an artifact, as now they are both gone!
Posts: 83
Joined: 08 Sep 2012, 06:58

Re: Command not found-Linux

#2 Post by Lito »

I do not use Mint, but might be you can type
the system should ask for the root password.
If it doesn't try:
su -

Once you become superuser, just type


Perhaps it would be better to run TestDisk or PhotoRec from a bootable CD/DVD.
Parted Magic, Knoppix, Ubuntu, or any distro of your choice.
Make sure you save the files you pull to a different device and that you have ample space.

Best of luck
Posts: 4
Joined: 20 Dec 2013, 15:53

Re: Command not found-Linux

#3 Post by Stuartf »

That did it!!

Many thanks for your help