Cannot run testdisk Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 4
Joined: 20 Dec 2013, 15:53

Cannot run testdisk

#1 Post by Stuartf »

I am running Mint 15, installed the program via software manager and tried running it with each of the commands in sequence:

sudo testdisk-6.13/photorec_static
sudo: testdisk-6.13/photorec_static: command not found

sudo testdisk-6.13-lubuntu2/photorec_static
sudo: testdisk-6.13-lubuntu2/photorec_static: command not found

I tried the lubuntu variation as that is what the program is named in software manager.

Any idea how I can get this to run, having deleted a bunc of files that Picasa showed as duplicates, but which apparently were not!

User avatar
Site Admin
Posts: 5422
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Cannot run testdisk

#2 Post by cgrenier »

Looks like your problem is related to your own computer usage...
If the program has been installed via a package manager, "sudo photorec" may suffice.
If it has been installed via an archive, use the "ls" command to list your files, "cd" to change of directory and once you have the correct program name, use sudo to run it.

Posts: 4
Joined: 20 Dec 2013, 15:53

Re: Cannot run testdisk

#3 Post by Stuartf »

Indeed, sudo photorec did it, which was not consistent with the instructions I read, live and learn!