PhotoRec stuck and jumps in infinite recovery loop

Using PhotoRec to recover lost data
Post Reply
Message
Author
Consumer2716
Posts: 1
Joined: 01 Jan 2014, 22:05

PhotoRec stuck and jumps in infinite recovery loop

#1 Post by Consumer2716 » 01 Jan 2014, 23:03

Hello everyone,

After a failed partition merger with non-backed up files, PhotoRec has been stuck on cluster 80,000,000 / 980,000,000 and keeps changing clusters from 74,000,000/78,000,000/80,000,000 and 81,000,000 for around five hours after which I manually oborted. I could hear the HDD reader head doing the same odd clicking noise over and over again.
>>> Is there any way to force PhotoRec to skip sectors it has difficulties reading after 10 or 20 tries and move on to the next one? <<<

Prior to the merge, I used to have two partitions on my laptop's 500GB Hitachi Travelstar HDD (purchased in 2009) with the following division:
(C:) Win7 64Bit 100GB - Partition: NTFS, Primary
Contained Windows 7 64Bit and all programs
(D:) Data 365GB - Partition: Extended, Logical
Contained all my photos, videos, music, documents, books etc.

A few days ago, I added a 250GB Samsung 840 Evo to my laptop on which I installed Windows 7 64Bit without any issues. However, Paragon Partition Manager 10 got stuck at 37% when I wanted to do the following.
500GB Hitachi Travelstar
1) Format (C:) 100GB Primary partition
2) Delete (C:) 100GB
3) Resize (D:) 365GB Extended partition to full 465GB
4) Resize (D:) 365GB Logical partition (inside extended partition) to full 465GB

I aborted the merger after 10 hours and then both partitions were not recognised by Windows which is why I initialised them in Computer Manager and then I did the following in Paragon Partition Manager 10 to recover the files.
1) Delete entire disk
2) Create Primary Partition (completed without any isues)
No new files were written on the 500GB Hitachi since the merger failure.

I then ran a deep scan in O&O DiskRecovery 7 to look for files and found around 2TB, but when I recovered what appeared to be all the lost data, almost everything was corrupted.
Then I ran TestDisk which told me everything was fine, and as mentioned above PhotoRec now gests stuck at less than 10% of the entire disk which is very frustrating.

Right now I am also running a 35x deep scan with Recuva in the hope of retreiving non-corrupted files, but that will take another 12 hours or so.
Interestingly PandoraRecovery aborted a deep scan after 1% due to a non-specified error.

If there is anyone that could help me, I would really appreciate this!

Many thanks
Harry

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3615
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: PhotoRec stuck and jumps in infinite recovery loop

#2 Post by cgrenier » 04 Jan 2014, 08:48

A possibility is to edit the photorec.ses file (backup the file first) with a text editor (ie. notepad).
Near the end of the second line, you will see something like "12345,inter".
This number is the sector offset, modify it.

The recommanded way remains to clone the damaged disk to a new empty disk using gnu ddrescue and to use PhotoRec on the clone
http://www.cgsecurity.org/wiki/Damaged_Hard_Disk

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests