USB thumb drive recognized but not accessible

Using TestDisk to repair the filesystem
Post Reply
Message
Author
Potemkin
Posts: 2
Joined: 21 Jan 2014, 19:31

USB thumb drive recognized but not accessible

#1 Post by Potemkin » 21 Jan 2014, 19:53

First of all I admit that I'm not entirely sure which subsection I'm supposed to post this in or which tool I should use, but please move the thread if it's in the wrong place.

Here's all the info I've posted on other support forums before being recommended TestDisk:
I'm having an issue with my USB thumb drive. I'm on my dad's computer; an old but serviceable thing running XP Home with SP3. The thumb drive is a Kingston DataTraveler 111, 16GB USB 3.0. It has worked perfectly on this computer and others for the past year (got it in January of 2013) and has not seen any abuse or accidents. It's been used quite a lot, but not excessively so (whatever that means) and certainly hasn't had to work any harder than could reasonably be expected of it, especially considering it's a quality brand.

The problem specifically: In the past two days or so, on two occasions, there's been the issue where you're "in" the drive file structure in Explorer and have been using the thumb drive for a bit, but suddenly the next double-click you do prompts you to insert a disk in DRIVE G: (the assigned letter on this computer). No huge thing: I just remove the thumb drive, reinsert it and am good to go again.

Just a short while ago, however, the problem took a turn for the worse. The same thing of Explorer (after me trying to open a file) suddenly saying there's no disk in drive G: and prompting me to insert one (you probably know the little window I'm talking about). Any text documents and what have you stay open however, and it's not until I try to save them that the problem shows itself.

This time, removing and reinserting the thumb drive didn't work as well, because what happened was that Windows after recognizing that something had been plugged into the USB port (which I suppose is "good" seeing as the last thumb drive that died on me didn't even elicit that much of a response from the system) didn't realize that it was the old familiar one, and instead started installing drivers for it, and they weren't even the drivers for DataTraveler111, but rather for "USB DISK 30X USB Device" which I've never heard of before. Anyway, once it was installed and done I tried to access it, but that had the same result as before the new driver install, which is that when I click "Removable drive (G:)" I get a prompt to insert a disk in drive G:. So basically the thumb drive shows up in Explorer as a drive but cannot be accessed because I'm prompted to insert a disk upon double-clicking it.
* * * * *
1. I went into the Device Manager in XP (I'm assuming it ran with admin rights because there's only one account on this computer, and it's the admin one) to have a look. Expanded the USB-branch but found no yellow icons signifying a problematic entry. Same in Win 7.

2. Then I checked out Disk Management in Windows XP. I'll just attach a link to a screencap of the Disk Management window. It's in swedish, but I think you'll get the gist of it. Sorry for the rubbish quality.

http://minus.com/i/emIU2BuvrqlS

In the topmost list, the thumb drive doesn't show up. It only shows the internal HDD (in three partitions: C through E) and the external one Seagate (H: ). But I think that's as it should be.

In the list below, the thumb drive is listed, as Disk 2 (G: ). Removable. It also says "No media" meaning (I think) that Windows treats it as a drive which is connected but into which it thinks a disk is required to be inserted. Like a DVD-reader, basically, I suppose. But on some level it must know it's a USB-device because it installed it as USB DISK 30X USB Device. It's all a bit peculiar.

3. I used a tool called USB Oblivion that erases all history of USB flash devices on the system. Having done that and restarted the system, the thumb drive was installed as USB DISK 30X USB Device once again. Same issue as before.
So, could this be a problem that TestDisk or PhotoRec might help with?

Thanks in advance for all and any help!

Sponsored links

Lito
Posts: 83
Joined: 08 Sep 2012, 06:58

Re: USB thumb drive recognized but not accessible

#2 Post by Lito » 01 Feb 2014, 13:46

In Windows XP the Administrator account is invisible. If you have only one account in your Dad's PC, you are right,
it has got administrative rights, but it is not he Administrator account.
If you are connected to the Internet with this PC, disconnect it now.
For a quick test, try the Switch User feature of Windows. Choose to log in as Administrator. For a password just press Enter, unless you or your Dad know otherwise. If you can acces by pressing Enter, unless you are very lucky or if the PC never has been connected to the Internet, you will have a lot of things to put right. You will need time and patience.
These things do not fix your USB pen straight away. Feel free to disregard.
Safely disconnect the bigger USB HDD (SeaGate Expansion Drive). This will make sure that its data stays safe.

To get to the Administrator account, reboot the machine and press the F8 key just before Windows starts. It might take a few tries before getting th hang of it. You should see what it looks like a DOS screen, telling you to Start XP in Safe Mode or to Press F8 for more Options. Choose Start in Safe Mode. Get to the Control Panel, Open Users Accounts and modify the Administrator's account.
Give it a password (as strong as you like or be able to remember). Tick the box Make Files Private.
There online places to check for password strength. Microsoft has got one. Or you can check Gibson's Research site http://wwww.grc.com/ and look at the HayStack feature.
At a later date you could use his Shields Up feature to check how safe is your computer.

The next stage would be to reset the password you currently use with Admin rights. Follow this by creating a new account with User rights only, for everyday usage. You can connect to the Net to update AntiVirus or similar things.

Next step would be to scan the XP machine with Kasperskys Rescue CD. You can download it from:

http://rescuedisk.kaspersky-labs.com/re ... cue_10.iso

You can burn the iso file to a CD using ImgBurn, Nero, or similar software.
Windows 7 also allows you to burn iso images to CD.

You will need to boot from the CD. Be aware that you must press a key pretty quick to get to choose the graphical interface.
Also you'll need an ethernet cable to connect to the internet (this is to get the databases up to date).

It might be also useful to scan the PC with SpyBot Search and Destroy

http://www.safer-networking.org/dl/

For security you can compare the checksums of the files downloaded with Cyohash

http://sourceforge.net/projects/cyohash/

------------------------------------------------------------------------------------------

Customers points of view for this USB device:

http://www.amazon.co.uk/product-reviews ... ewpoints=1
After reading that lot, I suppose quality is in the eye of the beholder.
The good news is that there many other USB sticks for about the same price. So making a clone would not break the baank.

Follow the instructions given in this page:

http://www.cgsecurity.org/wiki/Damaged_Hard_Disk

It does explain how to clone your disk or create an image.
TestDisk also allows you to make an image of the drive.

Kingston Support - There are no downloads or drivers available for this product:

http://www.kingston.com/en/support/tech ... odel=DT111

But there are a lot of Questions and Answers in the same page. Such as:
"The computer recognises the DataTraveler if it is inserted during boot, but it is not recognised if I insert the device while the computer is already on. How do I resolve this?"
You can check your Dad's PC to see if this simple tip has been implemented.

Updating the PC's BIOS also might help. You will have to search the manufacturers web site until you find a match.
Installing the latest version of the Chipset software for the PC might also help.


USB Disk 30X USB Device . Driver Download

https://www.pcpitstop.com/libraries/dri ... evice.html

This clearly contradicts Kingston support web page for your drive. Remove it from your computer.
Leave the drive in the machine for now and go Device Manager. Select Show Hidden Devices from the pulldown menus.
Rather than looking for yellow warnings, look a the list of Disks. Uninstall the reference to your USB stick.
The machine will restart. When it goes for the power cycle, remove your USB pen.

You can run msconfig to delete or block any references that would restart the USB-DISK-30X.... programme.
In the control panel look for Administration Tools and in there lok for Services. Check for any reference to the programme.
Delete or Disable.

Also from the Control Panel, double click on System. Choose the Remote tab. Get right in to the next section (for Invitations). Change the time settings to the absolute minimum allowed. Then take the tick away from the box allowing outside connection. Go back the main Remote tab and untick the box that allows somebody to takeover the PC. This are basic things to do. Unfortunately for your Dad, XP is facing the end of the road.


Some people "joogle" (move from side to side or up and down) their USB devices to disconnect them from the PC as opposed to pull them straight back. So damage can occur even if the device has little usage.

YouTube Video - USB Memory Stick repair....

https://www.youtube.com/watch?v=6sK-J29zr10

Another video showing a repair using the built in chkdsk


Microsoft Support

http://support.microsoft.com/kb/2654149

http://support.microsoft.com/kb/308421


Tools like CCleaner from http://www.piriform.com/ will help to automate a lot of the clean up.

Auslogics Disk Defrag will you time defragmenting your disks pretty fast.

Other hints and tips

http://www.pcworld.com/article/2054425/ ... grams.html

If and when you manage to copy and save the data in the USB pen, you could format it with

http://www.pcworld.com/product/946261/h ... -tool.html


Best of luck

Potemkin
Posts: 2
Joined: 21 Jan 2014, 19:31

Re: USB thumb drive recognized but not accessible

#3 Post by Potemkin » 01 Feb 2014, 14:50

Wow, that's an exhaustive reply! Thanks a lot for all that work. I'll look into each of those points and report back as soon as possible.

The crummy part of this is that I made an HDD backup of the USB stick's content before going traveling in South America for most of 2013, but that HDD also saw it fit to give up the ghost while I was away.

I've managed to salvage the most important stuff off of my dad's HDD (I kept the entire content of the USB stick there for a while and susequently deleted it, but using file recovery programs to get to it back worked only partially as the files had been fragmented since) but I would like to get access to the rest of the stuff as well.

Again, thanks a bunch, and I'll get cracking on trying those suggestions.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest