Even partition map is gone?

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 7
Joined: 24 Feb 2014, 17:16

Even partition map is gone?

#1 Post by toke »

I'm new here and with testdisk and have only mediocre skills with computers and filesystems.

I dropped a cup to my mbp's that corner, where hdd is.
First windows saw all partitions. When I could use another mac, I tried to repair hdd with Disk Utility, but it said it can't. Then I searched this Testdisk and tried to see what it could find. I got 220 MB's "image.dd. Now DU or testdisk can't find any volumes and testdisk can't even find the disk (disk6 in my config, yes, in sudo mode).
DU says "The disk you inserted was not readable by this computer."

I guess testdisk can't find partition table or partitions if it can't see the disk?
Maybe hdd is just "too" broken?
I'm still wondering why testdisk does not see disk6 when DU can see it?
Is it so that testdisk does not show disks without volumes?