Raspberry Pi dd mistake- burned disk image to external HD

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
monkmandolins
Posts: 1
Joined: 07 Mar 2014, 14:56

Raspberry Pi dd mistake- burned disk image to external HD

#1 Post by monkmandolins »

Hi there-
I saw a few posts on this here already, but none seemed fully resolved.
Here is the situation:
I am using Linux Ubuntu. I downloaded the Raspberry Pi operating system image which is a .img file.
I tried to burn this disk image to an SD card while my external drive was connected.
The external drive is 1 TB, and has about 900 GB worth of stuff on it. It actually belongs to my friend and is a windows-oriented hard drive.

Anyway, I accidentally burned the Raspberry Pi .img to the external hard drive, and now I can't access the contents of the drive.
The first thing I did, like an idiot, is go into the 2 partitions that were created "boot" and "rootfs" and deleted the contents of these new file systems. My thought process, besides being totally stupid, was that I would prevent the drive from booting to these partitions. I then managed to delete the rootfs partition.

What I have now is: 4.2MB free space, 59MB FAT, 1.0TB Free Space.

None of what I did took very long, which I am hoping means that the data is still on the harddrive in that free space area.

What do you think, aside from me being an idiot?
What i have now, when the device is plugged in, is simply the boot partition showing up on my home screen.

THANKS SO MUCH!
Peter

Sponsored links

Locked