WD My Book power died

How to use TestDisk to recover lost partition
Post Reply
Message
Author
FuriousD
Posts: 2
Joined: 11 Mar 2014, 03:43

WD My Book power died

#1 Post by FuriousD » 11 Mar 2014, 04:08

Ok so about three days ago my 3TB Western Digital My Book external drive decided that it didn't want to be powered on anymore. It was connected fine and everything was good for years. Then one night i notice its no longer connected. I thought the drive had died, however i noticed the enclosure wasn't getting any power at all. So i took the drive out of the enclosure.

Upon plugging the drive into the computer via esata and a separate power supply the drive showed up as unallocated. Frustrated i searched the web. Multiple people had the same problem with their WD my book drives. They suggested to use TestDisk to recover the partition. So thats what I'm trying.

The disk only had one partition on it, just one giant NTFS partition. So I looked at all the guides and ran TestDisk. Testdisk told me that it thought the drive was an "EFI GPT" partition so i went with it. Then I hit analyze, and then quick search.

The quick search took over three days. Finally today it finished. It's sitting with a screen that now has three rows in green.

The first one has "M-<^CM-4c?M-pp 7]" followed by start and end numbers..
the second one has "P MS Data" followed by start and end numbers
the third one has "P Mac HFS" followed by start and end numbers.

So that's where I'm at. I have no idea what to do next. All the guides tell me i'm supposed to see an NTFS row and stuff. I see nothing like that. I'm afraid to do anything if its going to take another 3 days to quick search the drive. Is there any way to save the quick search it already did? That way if I exit out of this but want to go back to it i can?

So yeah no idea what to do. Any help is greatly appreciated. I'll post the log when I get home from work.

For the TL;DR people out there:
I'm a total noob. Please help. I read all the guides and my experience is not matching up with any guide or forum post. What do I do?

Sponsored links

FuriousD
Posts: 2
Joined: 11 Mar 2014, 03:43

Re: WD My Book power died

#2 Post by FuriousD » 12 Mar 2014, 09:48

So uh.

Upon further reading, I went ahead and messed with some stuff. TestDisk couldn't list any of my files, so I decided not to write anything to the hard drive. I've currently tried a few programs to recover the partition, nothing seems to be working. I tried Partition Guru to recover some files, but oddly enough all it found were some really messed up files with sequential names that won't open, and a bunch of user manual documents and photos from Western Digital. I'm assuming it was stuff that was on the drive before I ever formatted it. Maybe thats what TestDisk found as well.

Anyway, I'm trying all sorts of different programs now, but I don't have much faith. Nothing seems to see my lost partition. My last ditch effort will be to go buy a new WD My Book external drive, bust open the enclosure and put my drive in the new enclosure. Maybe their hardware does some magic that will let my computer see the drive normally. But I doubt it.

So confused by all this though. All the SMART stuff says the drive is healthy. No clicking or anything. Just bam, one day the enclosure stopped getting power, and the drive shows up as unallocated. I've read a bunch of things on the forum with people having the same EXACT problem, but none of their solutions are working for me.

Anyway let me know if I did anything wrong with my TestDisk scan, or if anyone has any other ideas. I appreciate any help.

UPDATE:

Final reply probably...

So I did some more digging. Turns out WD My Book 3TB drives are all hardware encrypted. Only way to see the drive is to plug it into the PCB. My PCB is busted. Currently trying to find a new PCB that will hopefully work with it. Sigh. Thanks to anyone whose read this. Sorry for wasting time.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests