Can't unmount hard drive?!

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
tonyterence
Posts: 1
Joined: 15 Mar 2014, 21:28

Can't unmount hard drive?!

#1 Post by tonyterence » 15 Mar 2014, 21:39

I'm trying to recover two lost partitions and have successfully managed the first one. The second one contain (among lots of other things) a bootable .dmg file that was also successfully recovered and it is this "disk" that now shows up when I boot the hard drive.
BUT, I want to do another search with TestDisk to find the other files still not the hard drive but for some reason I can't unmount the hard drive (which I have to do to run TestDisk properly)! Disk utility keeps giving me an error message and refuses to unmount the drive.
I have installed "whats keeping me" and can find no process running on the drive. I have tried several force eject/unmount commands in terminal, I have tried re starting the computer and so on. Nothing seems to help and this is driving me crazy! Please, can someone help me?

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests