Undelete files from VMFS

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 25 Mar 2014, 08:54

Undelete files from VMFS

#1 Post by daveloper »

I've a 2TB partition formatted with ESXi as VMFS 5 and one of my stuffs accidentally removed all of my VM files from it.
I tried Disk Internals VMFS recovery and it founds some files from it but not all of them, specially snapshot files.
Now I'm trying PhotoRec to see if it's possible to recover my lost files.
Is there any way is to undelete them using TestDisk?

User avatar
Site Admin
Posts: 5422
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Undelete files from VMFS

#2 Post by cgrenier »

TestDisk will not work in your case. What have been the results with PhotoRec ?

Posts: 1
Joined: 01 Jul 2014, 12:33

Re: Undelete files from VMFS

#3 Post by muratakpinar7 »


I have same problem. When I use Qphotorec_win, it is finding VMDK file. However, this vmdk file's has wrong partition ID. ESXi 5 use real partition. When I look recovered vmdk file, I see different partition type. Qphotorec finds vmdk file. But I think it use wrong INODE table.

I know my deleted vmdk file sectors. However, I cannot see INODE table. I cannot see recover whole file. My deleted file size is 2 TB. Qphotorec finds correct file size. But wrong file content.

Please review my attachment. If you help us, we will glad to you. Thanks for everything. Testdisk and photorec are great programs.

Best regards.
qprotec_win recovery screens.
qprotec_win recovery screens.
QPhotorec_win Rec Screens.png (223.37 KiB) Viewed 7131 times