Photorec Recovers on HDD but not on SSD

Using PhotoRec to recover lost data
Post Reply
Message
Author
cyrex
Posts: 3
Joined: 26 Mar 2012, 17:28

Photorec Recovers on HDD but not on SSD

#1 Post by cyrex » 10 Apr 2014, 02:33

This is a weird problem I am having and yesterday I thought about testing if the problem was the SSD. My curiosity started because I had a couple of png files deleted and wanted to recover them. They were deleted the day before the recovery (1 day ago from recovery). The recovery worked on an HDD I had but not on the SSD which had the original images. (I had copied the images from the SSD to the HDD a day ago).

I wondered, why, the images were recovered from the HDD but not the SSD so, just for curiosity, I put a couple of images I had in the SSD to the HDD and then proceeded to delete the images from the SSD. Waited for one whole day (And even turned off the PC) and then ran photorec to recover the images. I did NOT recover any of the images I deleted, in fact, I did not recover any images whatsoever. But I did recover them from the HDD.

So I have a question, does an SSD somehow change the way data can be recovered.

The SSD in question is the Samsung 840 PRO (256 GB). Do I need some special parameters to recover files from an SSD because, not only did it not recover any PNG images from the SSD that I had deleted previously but I even tried recovering any PNG images in the whole drive, not limiting this to the only PNG images I had removed and not images were recovered.

I am on Ubuntu 13.10 64 Bit, both HDD and SSD are Ext4. I am using Photorec 6.14.

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests