Seagate 3tb crapped out, need help

How to use TestDisk to recover lost partition
Post Reply
Message
Author
senlim
Posts: 2
Joined: 20 Apr 2014, 14:32

Seagate 3tb crapped out, need help

#1 Post by senlim » 26 Apr 2014, 18:12

My system is basic: intel atom d510 with 4GB RAM, integrated video, 1TB hdd (working, OS is windows 7 64bit). I added a seagate 3TB last year. 3TB hdd is for storage only. I don't remember but I think it only had one partition.

Last month: computer wouldn't boot. Took both HDDs out. The 1TB hdd had problem, fuzzy memory but ended up formatting it and used recuva to recover files. Reinstalled win7 64bit again and it's working.

Problem comes when I attach the 3TB hdd. BIOS comes up real slow. Also sticks at "Starting windows" for a long time. When finally done, three partitions were found on the 3TB hdd, I must have tried to reinstall win7 on that hdd (remember, fuzzy memory). Files I want are in one of the larger partition. I tried to copy them but stuck at "discovering files...". System was real slow (crawling).

I used testdisk (v6.14) and did whatever it does (forgot exact steps but I told it to write something as it found some issues). Problem persists.

I went to seagate.com/beyond-2tb and it says it does not need any drivers for win7 64bit for data (not boot). However, the 3TB hdd is "MBR" not "GPT" like seagate.com/beyond-2tb suggests. So I used AOMEI partition assistant (standard 5.5) and converted it to GPT. Slowness remains but now the hdd is not being detected by win7.

BIOS detects it as 800GB only.
SATA controller is set to IDE. I changed it to "AHCI" and system wouldn't boot (it restarts itself at "Starting windows") so I switched it back to IDE. It boots fine now but again no 3TB hdd.

AOMEI partition assistant does not see the 3TB any longer.
Intel atom d510 says it supports UEFI but I don't know what it is nor if I need to bother with it.

What should I do now?

Thanks.

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests