directories recursively defined inside the disk

Using TestDisk to repair the filesystem
Post Reply
Message
Author
pauloney
Posts: 1
Joined: 28 Apr 2014, 20:49

directories recursively defined inside the disk

#1 Post by pauloney » 29 Apr 2014, 04:35

I have a Linux/Windos box that went bad after the last update of Windows 7. It gave a grub-error back and never booted again. After trying to recover the partition without sucess. I moved on to recover the data inside the partition with TestDisk. Initially things went well, but soon a home directory that was supposed to have only 200 Gigs fill out a 500Gig disk. I changed to a 1 Tera, same thing happened - the disk went full before the process of recovery could be finished. Tried with a 2 Tera disk and the same thing...

So, looking in a bit more detail I found some 8 occurrences of this odd thing! A "unsuspecting" file (in general a figure) would be turned into a directory and that directory would contain a full copy of the Linux installation, like in:

Code: Select all

paulo@ubuntu:cd  /media/paulo/Seagate Expansion Drive/home/paulo/KnotFigs/10_37.eps
paulo@ubuntu:/media/paulo/Seagate Expansion Drive/home/paulo/KnotFigs/10_37.eps$ ls
bin    etc    lost+found  proc  selinux  updmap.texlive.new
boot   home   media       root  srv      updmap.texmf.new
cdrom  lib    mnt         run   sys      usr
dev    lib64  opt         sbin  tmp      var
and this would happen in a few other places as well - and fill up the disk being used for recovery.

I have now (3 days into the process) chased some 30 occurrences of the entire Linux installation inserted at some point of the disk, and I am suspecting more and more this to be a bug with TestDisk rather than a problem with the data in the disk. My main reason is:

It only occurs at very specific types of files, 4 I have found: .eps, .pdf, .mf and .log (both from TeX).

Anyone has any thoughts on what the problems is ?

Paulo

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3553
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: directories recursively defined inside the disk

#2 Post by cgrenier » 02 May 2014, 09:03

Do you have the problem with latest TestDisk 7.0-WIP ? If it's the case, please post the testdisk.log file section corresponding to a directory listing where there is a file causing this loop.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests