GoPro MP4s won't playback

Using TestDisk to undelete files
Post Reply
Message
Author
jadamburke
Posts: 1
Joined: 07 May 2014, 05:48

GoPro MP4s won't playback

#1 Post by jadamburke » 07 May 2014, 06:10

I've checked some other forum posts on the GoPro issues... they focused on PhotoRec and fragmented files though so i'm posting my issue here.

I lost a few movie clips accidentally and was fortunate enough to still have the wiped SD card available for data recovery. I was able to do an undelete using testDisk on the lost mp4 clips, but they are not playable. They play as black in the Finder preview. Other applications also can't read the files. I have a few clips still left on my desktop to compare with what testdisk restored. The filename, date, and size all match, but when i did a binary diff between what testdisk restored and an original mp4 clip. only the first 64K (65524 bytes) matched. the rest of the file was not the same. Any idea why its completely wrong?

JPEG files all worked fine... I've also tried photorec on this, it generates _ftype.mov files still nothing is playable. generates a report.xml with this error: error on line 172 at column 4: Extra content at the end of the document. maybe this is related?

on OSX 10.8.5. SD card is FAT/FAT32. SD card was brand new, has not been overwritten or used since.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3754
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: GoPro MP4s won't playback

#2 Post by cgrenier » 07 May 2014, 07:47

If you have a recent GoPro, it generates for each video a mp4 (high resolution video) and a lrv (low resolution video), you may also have a thumb image file.
These 2 video files are intertwinned when written to the disk, so data recovery utilities like PhotoRec will not be able to handle the high level of data fragmentation. It's something where you need to contact a data recovery company like myself. If you are interested, you can contact me by private email.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests