Testdisk not displaying all files in a very large directory

Using PhotoRec to recover lost data
Post Reply
Message
Author
piotrus
Posts: 2
Joined: 04 Jun 2014, 12:53

Testdisk not displaying all files in a very large directory

#1 Post by piotrus » 05 Jun 2014, 04:30

Hey guys,

First, I've noticed this forum section is for PhotoRec, but also file recovery. I am currently using TestDisk to copy files, so if my post should be somewhere else, apologies for a newbie confusion and please move my thread.

:Background, skip if not interested
Now. Few weeks ago my external hdd drive failed: started to work very slowly; I copied me files, then my Windows stopped being able to recognize it (displays drive letter, but cannot access it). Checkdisk looked like working, but did nothing. Testdisk, however, was able to acccess it, showing file directories and files as all there. I am slowly copying the content, which so far looks 100% undamaged, at the speed of 1 gb and hour (the drive is 1.5TB so yeah, it's going to be a while). The drive works in spurts - transfers few hundreds megs at top speed then mulls few megs for half an hour or so and cycles between those two modes, and in the slow mode it's making a repeated z-z-z-z-z noise, maybe like two 0.3s z followed by 0.3 quiet (some of you may figure out what's wrong based on those symptoms, but that's not what I am asking, it's just background info in case it matters...).

:Problem - what I am asking about
Anyway, while I am ok with the speed (not happy, but if I can recover my data in a month, oh well), the problem is that one big directory seems to not to display fully. This directory had several subdirectories and many (over a thousand?) files. When I use testdisk navigation to go there, it doesn't show any subdirectories, instead I get an alpabetical list of files from 0 to somewhere around b. There's no function I see to tell testdisk to "go to the next page listing", so since all other directories I've tried display fine, I am assuming that there's some kind of overflow bug, where testdisk lists the first (1000? didn't count) files and then stops.

Let me know if there's a workaround. The only idea I have at this point is to tell testdisk to copy the entire parent directory but it's hundreds of gigs, and I don't need all of it. I'd rather copy just some files...

On a related note, there wouldn't be an option to tell testdisk to only display / copy files with a certain date range? I have a backup of about 80% of this data (from 2012). If I could tell testdisk to only copy all files from a specific date in 2012 onward, it would save me a lot of time (and as the disk will probably fail at some point, anything that can save time would be good).

Oh, I am using the beta 7.0 version. Haven't tried the stable 6 yet.

One more oh. I discovered an unreferenced feature in testdisk (at least I didn't see it on the wiki): Page up and down speed up scrolling through list of files. Maybe worth noting somewhere, perhaps even in the testdisk user interface?

Thanks for any help and advice you guys can offer - cheers.

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests