Okay, this is my WD 3TB problem.

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Deity666
Posts: 19
Joined: 29 Jul 2014, 20:40

Okay, this is my WD 3TB problem.

#1 Post by Deity666 » 05 Aug 2014, 19:07

I bought a WD30EZRX (-00D8PB0) 3TB around November last year and must admit my knowledge of Advanced Format drives and their issues with XP Home was...lacking. I had to call WD for help using their software - which I understand to be a stripped down version of Acronis to install it. I can't remember if the tech simply helped me create partitions on it or started me on formatting as well. I don't know if the sectors needed to be aligned or not.

I want to say the first partition was a little over 2TB with a 2nd one of 740+. One day, the first partition disappeared. I suffer from chronic pain and lack of money, so since I had already started using the 2nd partition, I recovered as much of the info from the first as I could instead of trying to recover the first partition. Under the heading of "No good deed goes unpunished" I decided to clean up my system, reconnect cables to make things tidier and voila, the 2nd partition vanished as well. Testdisk has once again allowed me to recover as much of the data as I had room for.

I have been working on this for a few weeks - between reading about it, trying things I've read here - and the best I've been able to get it was being able to access the data. So here's where the journey starts with images and descriptions - it's ongoing, so maybe I need help more than I thought when I started capturing the images last night.

After the initial launch of Testdisk 7 (I've also tried the earlier 6XX), I selected the 3000 GB drive from the list of drives. The page said it detected a EFI GPT partition, and since I've read that that's what I should try, I selected it.
Selected EFI GPT option resized.jpg
Selected EFI GPT option resized.jpg (21.72 KiB) Viewed 845 times
Which brought up this screen:
1st search after detection of EFI GPT partition resized..jpg
1st search after detection of EFI GPT partition resized..jpg (14.14 KiB) Viewed 845 times
I selected Quick Search. This is a moment in time of the process.
Screen Shot after starting search.jpg
Screen Shot after starting search.jpg (25.05 KiB) Viewed 845 times
I can't seem to add another image. Will continue.

Sponsored links

Deity666
Posts: 19
Joined: 29 Jul 2014, 20:40

Re: Okay, this is my WD 3TB problem. Edited.

#2 Post by Deity666 » 05 Aug 2014, 19:14

After 3TB WD drive went thru EFI-GPT detection of partition.jpg
After 3TB WD drive went thru EFI-GPT detection of partition.jpg (40.45 KiB) Viewed 794 times
And five hours later, I awoke to this:
Hours after the last screen capture. Bad sectors.jpg
Hours after the last screen capture. Bad sectors.jpg (27.74 KiB) Viewed 844 times
My guess is the drive has three partitions, a small Acronis bridge that allows for XP to see the larger drive, than the two real partitions. I'll be righteous and admit I'm wrong if it's explained. By no means do I think I know everything - in fact I'm struggling just to try to understand this.

This is what existed of the Testdisk.log at time of making it with a slight update to it when the mention of a floppy disk is listed - I put one in my drive to see what was on it.

Physical drive 4 is the one I'm struggling with.

Tue Aug 5 02:34:39 2014
Command line: TestDisk

TestDisk 7.0-WIP, Data Recovery Utility, June 2014
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows XP SP3
Compiler: GCC 4.7, Cygwin 1007.25
Compilation date: 2014-06-21T09:12:27
ext2fs lib: 1.42.8, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=1000203804160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=2000397852160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdc)=1000203804160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdd)=1000204886016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sde)=3000591900160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdf)=2000398934016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdg)=16000221184
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdh)=300067970560
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=1000203804160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=2000397852160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive2)=1000203804160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive3)=1000204886016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive4)=3000591900160
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive5)=2000398934016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive6)=16000221184
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive7)=300067970560
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=1000202241024
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\D:)=1000202241024
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\E:)=15999094784
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\L:)=300066407424
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\U:)=1000202241024
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\V:)=2000396289024
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\W:)=2000395755520
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\Z:)=2090336256
Hard disk list
Disk /dev/sda - 1000 GB / 931 GiB - CHS 121601 255 63, sector size=512 - Hitachi HDS721010CLA332, FW:JP4OA3MA
Disk /dev/sdb - 2000 GB / 1863 GiB - CHS 243201 255 63, sector size=512 - TOSHIBA DT01ACA200, FW:MX4OABB0
Disk /dev/sdc - 1000 GB / 931 GiB - CHS 121601 255 63, sector size=512 - Hitachi HDS721010CLA332, FW:JP4OA3MA
Disk /dev/sdd - 1000 GB / 931 GiB - CHS 121601 255 63, sector size=512 - ST1000DM003-1CH162, FW:CC49
Disk /dev/sde - 3000 GB / 2794 GiB - CHS 364801 255 63, sector size=512 - WDC WD30EZRX-00D8PB0, FW:80.00A80
Disk /dev/sdf - 2000 GB / 1863 GiB - CHS 243201 255 63, sector size=512 - TOSHIBA DT01ACA200, FW:ABB0
Disk /dev/sdg - 16 GB / 14 GiB - CHS 1945 255 63, sector size=512 - PNY USB 2.0 FD, FW:8.00
Disk /dev/sdh - 300 GB / 279 GiB - CHS 36481 255 63, sector size=512 - ST330083 1AS
Drive Z: - 2090 MB / 1993 MiB - CHS 498 64 32, sector size=2048 - HL-DT-ST BD-RE WH14NS40, S/N:394b454b50333138303720392020202020202020, FW:1.01

Partition table type (auto): EFI GPT
Disk /dev/sde - 3000 GB / 2794 GiB - WDC WD30EZRX-00D8PB0
Partition table type: Intel
Disk /dev/sde - 3000 GB / 2794 GiB - CHS 364801 255 63
0000 e81401b9 f001be10 7cbf1006 57f3a4c3 ........|...W...
0010 8b4e1483 f90e7508 8d5e0743 0207e2fb .N....u..^.C....
0020 8c560c8c 560e7569 8a561084 d27962e8 .V..V.ui.V...yb.
0030 f800bbaa 55cd1372 6f3b5e5c 756ad1e9 ....U..ro;^\uj..
0040 7366b442 c6460201 eb6689b6 f6fe8a44 sf.B.F...f.....D
0050 0484c074 0f3c0574 0b3c0f74 078a1480 ...t.<.t.<.t....
0060 e28075cb 83c61006 c45c0889 5e088c46 ..u......\..^..F
0070 0a07fe8e f9fe75d2 b031c646 d5508846 ......u..1.F.P.F
0080 d2be6807 ac84c074 08b40eb3 07cd10eb ..h....t........
0090 f3e88300 884611be ae073c05 75c6cd16 .....F....<.u...
00A0 33d28956 0889560a e87f0072 1db80102 3..V..V....r....
00B0 bf05008b dc565050 5232e4cd 135a588b .....VPPR2...ZX.
00C0 f5cd1358 5e73034f 75e9b032 72b0408a ...X^s.Ou..2r.@.
00D0 66119e7b 04c64702 0e723575 0c885740 f..{..G..r5u..W@
00E0 c44e0889 4f1c8c47 1e79068a 4e12884f .N..O..G.y..N..O
00F0 2580c702 817ffe55 aa758381 7ffacd19 %......U.u......
0100 7509c647 fae9c747 fb9488e8 1c00ffe4 u..G...G........
0110 74ce8857 24ebc95d 33c08ed8 8ec08ed0 t..W$..]3.......
0120 bc007c55 bda207fc fbc3b408 5206cd13 ..|U........R...
0130 07722f33 db8ade8b 460a33d2 83e13ff7 .r/3....F.3...?.
0140 f191978b 4608f7f7 4287ca3b da721343 ....F...B..;.r.C
0150 f7f38af2 86c5d1e8 d1e80ac8 d0ccd0cc ................
0160 0af4b441 5b8ad3c3 0d0a4d42 52204572 ...A[.....MBR Er
0170 726f7220 000d0a00 72657373 20616e79 ror ....ress any
0180 206b6579 20746f20 626f6f74 2066726f key to boot fro
0190 6d20666c 6f707079 2e2e2e00 00000000 m floppy........
01A0 00001000 0100007c 00000000 00000000 .......|........
01B0 00000000 00000000 fc123408 00008001 ..........4.....
01C0 010007fe ffff3f00 00006da5 505d0000 ......?...m.P]..
01D0 00000000 00000000 00000000 00000000 ................
01E0 00000000 00000000 00000000 00000000 ................
01F0 00000000 00000000 00000000 000055aa ..............U.
Partition table type (auto): EFI GPT
Disk /dev/sde - 3000 GB / 2794 GiB - WDC WD30EZRX-00D8PB0
Partition table type: EFI GPT

Analyse Disk /dev/sde - 3000 GB / 2794 GiB - CHS 364801 255 63
hdr_size=92
hdr_lba_self=1
hdr_lba_alt=5860531054 (expected 5860531054)
hdr_lba_start=34
hdr_lba_end=5860531021
hdr_lba_table=2
hdr_entries=128
hdr_entsz=128
Current partition structure:
1 P MS Data 63 1565563759 1565563697

After getting to ~76% last night, my system locked up and rebooted so I'm back to an earlier point than I was.

Fiona or Chris, I'm hoping you've looked at this and since you haven't seen something big time wrong, is just waiting for more before saying something.

After a mistake Thursday morning that caused me to have to restart the process, I did and it finished a short while ago.
After 3TB WD drive went thru EFI-GPT detection of partition.jpg
After 3TB WD drive went thru EFI-GPT detection of partition.jpg (40.45 KiB) Viewed 794 times
I have not yet tried to see if either one will list. If I haven't included this in previous posts, this was never going to be a bootable drive, but I know it had two main partitions, maybe a third just created by the Acronis software. The first was 2+ a small amount and the other 740+ gigs. It worked fine for months,and then whether it was going from the free Acronis to the Seagate I had to install - which requires the uninstallation of the WD - or the installation of the retail copy I bought or none of these, I don't know. It may even have had something to do with BIOS changes when a different newer boot drive died and would not show up and I changed a setting - I didn't know it might have mattered.

I think what will happen now if I choose with one and get the option to look at the contents, I might be able to. I also know I might be at that stage that if i hit 'Q' to exit the choice, it throws me back out the analyze screen. Considering how long it took, I'm really hoping for a few words of advice from you before I try. It's 12:10 AM time which means Fiona, it may be 10:12 already for you? I'm going to watch a 60 minute show and then see what happens then, but it's past bedtime for me now - not meant to rush you by any means, just to let you know that from someone so interested in getting help, I;m in a number of different time zones than you. :oops:

So, Christoph?, how hard would it be to build in a 'save' position feature, so after 36+ hours of doing a scan and you press the wrong button, you could resume where you left off instead of having to do the entire thing all over again? Why, you ask?... Maybe it did better than not, but I thought I was at a point where I was willing to gamble writing a partition it had found, "unable to write" it reported and this time, I only had the choice of deeper search or quit and since I didn't think I could keep my system running for the next 56 hours, I hit 'Q' and was back at the analyze screen instead of back at the partiti

P.S. - am I doing anything wrong not to be getting a response? I know my pictures were not the same size and I have pet peeves of my own when it comes to grammar sometimes, so I was wondering if it was more than y'all being busy or just being long-winded...? :oops:

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests