Trying to recover partition after Intel RAID messed-up Topic is solved

How to use TestDisk to recover lost partition
Locked
Message
Author
Athar
Posts: 2
Joined: 19 Aug 2014, 09:42

Trying to recover partition after Intel RAID messed-up  Topic is solved

#1 Post by Athar » 19 Aug 2014, 10:07

Hi,

I know, this question has been posted a lot of time, but I didn't find all the answers I'm looking at.


So, I've an Asus Z97-Deluxe, when I update the BIOS, I always have a RAID0 that failed, but that time, I totally forgot this issue and I cleaned-up my backups from my NAS 2 weeks ago ('-_-).

So, I try to use some procedure on the net, mark all disks from the array to "Non-Raid member", well, was just one of the two drives in fact, then, I recreate the array, same name and parameters as before.
Disks are still connected to the same SATA ports, I didn't try to change them.

When I run Testdisk (from UltimateBoodCD, should be version 7 of TestDisk, not at home right now), I select the MD126 (which is my Intel RAID array).
TestDisk detect the "EFI GTP" partition type, which should be correct as I use the Windows GPT partition type on Windows for all my recent install now.
The RAID0 use 2x1TB Samsung HDD, and for the CHS, I have something like 4 2 for H and S, I don't think this is normal, so I change that to 255 63 but I only find EFISECTOR, boot or similar, never find any NTFS partition (even with Deeper search).

If I select "PC/Intel" partition type, changing the HS values to 255 63, I find 2 partitions, one that I deleted, and one that seems almost correct (not the good size, but still have a big part of the datas), but it still miss one of the partition, even with Deeper Search, I didn't find it.
After that quick Analyze, it tell me that the Heads size should be "64", so I also try with that value, no big changes, same results.


So, question: What can I do ?
- Change the SATA Ports ? (don't know why I should do that anyways)
- Calculate a better "CHS" value, but don't know how to proceed with an Intel based RAID0
- Put some C4 on it and push the red button... (last resort)

And which partition type should I use, "EFI GPT" or "PC/Intel", as it should be in GPT format but I've a doubt.


Thanks for your precious help (I try for 3 days to make that working, I'm running out of solution...)

Sponsored links

Athar
Posts: 2
Joined: 19 Aug 2014, 09:42

Re: Trying to recover partition after Intel RAID messed-up

#2 Post by Athar » 19 Aug 2014, 22:18

So, some news after this message, it seems that the EFI GPT Deeper scan make me find the correct missing partition. Copy is running, will do the same with the second partition when I'll discover it (there is a LOT of strange result, I maybe have 20 entries, maybe more, a complete mess, I plan to made a DD/Full erase for both drive before I reuse the RAID for those).

I hope to get all the files recovered, for now, I still recover some (which is still better than nothing in the end...)


Merci pour ce superbe programme, qui même s'il m'aura fallu du temps, m'aura surtout sauvé des données :)

(in short for the last phrase: Thanks for that great software).

Locked

Who is online

Users browsing this forum: Google [Bot] and 1 guest