Listing files causes crash

How to use TestDisk to recover lost partition
Post Reply
Message
Author
paulvbrown
Posts: 2
Joined: 05 Sep 2014, 16:37

Listing files causes crash

#1 Post by paulvbrown » 05 Sep 2014, 17:01

Hi!

320G hard drive was in Vista machine. Now in LiveCD Lubuntu, latest testdisk installed:

Code: Select all

Architecture: i386
Version: 6.14-1ubuntu1
Entire disk shows as unallocated space (289G) in gparted and has a warning, "/dev/sda: unrecognised disk label"

testdisk seems to go fine, finds the disk. Intel partition type --> Analyze --> reports partition doesn't have endmark 0xAA55, but QuickSearch finds 2 partitions. (20480000 sector "PQSERVICE" FAT32 and 604657664 sector "ACER" HPFS-NTFS)

P(list files) works fine for FAT32 partition, but when used w/2nd partition testdisk crashes and sends me back to command line. =o(

Tried a deeper search, but it did the same.

fwiw, here's the latest log:

Code: Select all

Fri Sep  5 15:43:21 2014
Command line: TestDisk

TestDisk 6.14, Data Recovery Utility, July 2013
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Linux, kernel 3.11.0-12-generic (#19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013) i686
Compiler: GCC 4.8
Compilation date: 2013-08-23T16:52:16
ext2fs lib: 1.42.8, ntfs lib: libntfs-3g, reiserfs lib: none, ewf lib: none
/dev/sda: LBA, HPA, LBA48, DCO support
/dev/sda: size       625142448 sectors
/dev/sda: user_max   625142448 sectors
/dev/sda: native_max 625142448 sectors
/dev/sda: dco        625142448 sectors
Warning: can't get size for Disk /dev/mapper/control - 0 B - 1 sectors, sector size=512
Hard disk list
Disk /dev/sda - 320 GB / 298 GiB - CHS 38913 255 63, sector size=512 - WDC WD3200BEVT-22ZCT0, S/N:WD-WXR0E39H2931, FW:11.01A11
Disk /dev/sdb - 4037 MB / 3850 MiB - CHS 1017 125 62, sector size=512, FW:PMAP

Partition table type default to Intel
Disk /dev/sda - 320 GB / 298 GiB - WDC WD3200BEVT-22ZCT0
Partition table type: Intel

Analyse Disk /dev/sda - 320 GB / 298 GiB - CHS 38913 255 63
Current partition structure:

Partition sector doesn't have the endmark 0xAA55

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3569
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Listing files causes crash

#2 Post by cgrenier » 06 Sep 2014, 14:10

Please try using TestDisk 7.0-WIP

paulvbrown
Posts: 2
Joined: 05 Sep 2014, 16:37

Re: Listing files causes crash

#3 Post by paulvbrown » 06 Sep 2014, 19:07

Argh. Why didn't I try that BEFORE spending the day watching PhotoRec rescue the files one-by-one.

7.0 worked beautifully. THANK YOU!!

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests