Need Help repairing 8GB FAT32 Flash Drive...

Using TestDisk to repair the filesystem
Post Reply
Message
Author
paperkart
Posts: 2
Joined: 07 Sep 2014, 17:53

Need Help repairing 8GB FAT32 Flash Drive...

#1 Post by paperkart » 07 Sep 2014, 18:30

Hello.

Long story short, my flash drive has become unreadable definitely due to not safely removing. It was formatted FAT32 using an Intel Partition Table. Now, It gives the standard "Do you want to format drive?" message (to which I say no), and I've been running TestDisk over the past week or so. The first event was fixed by rebuilding the boot sector, but this doesn't seem to be the case anymore.

The drive has stopped reading again.

When selecting my drive and selecting the [Intel] Partition Table and [Analyse], it comes up with no partitions and a "Partition: Read Error". Quick and Deeper searches produce nothing, though it states "Read Error" as it scans. [Advanced] also does not detect a partition.


When selecting my flash drive and selecting [None] for my partition table and [Advanced], it comes up with a Primary Unknown Filesystem drive displayed as [> P Unknown 0 0 1 1022 76036 16035840]

Changing the Partition Type to FAT32 and selecting [Boot] produces:

Boot sector
fat32_boot_sector: Can't read boot sector.
Bad

Backup boot sector
fat32_boot_sector: Can't read backup boot sector.
Bad

Sectors are identical.

A valid FAT Boot sector must be present in order to access
any data; even if the partition is not bootable.




I Tried to rebuild the Boot sector. It didn't find a FAT, and after it finished scanning, it said "Can't find cluster size".

Trying to undelete only wields "Can't open filesystem. Filesystem seems damaged."

I've been browsing through the forum trying to find answers, but to no avail. Also, I accidentally deleted my backup awhile ago, and undeletion doesn't really work. I've used PhotoRec to try and recover my files before, but organizing the files again is crazy considering just how many images are on it. I'm avoiding reformating the drive so I can try to recover the file system structure, but I don't have the money to spend on fixing the drive...

Right now I've booted up my PC with PartedMagic. I'm not familiar with Linux PCs, though. I have an image.dd of the drive saved to play with, but I don't know how... Please, any help would be appreciated.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3817
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Need Help repairing 8GB FAT32 Flash Drive...

#2 Post by cgrenier » 08 Sep 2014, 06:33

If you want to play with the image.dd file, select this file, right click, "Open with" and select TestDisk.

paperkart
Posts: 2
Joined: 07 Sep 2014, 17:53

Re: Need Help repairing 8GB FAT32 Flash Drive...

#3 Post by paperkart » 09 Sep 2014, 00:24

Thanks for the response! I opened image.dd using TestDisk, and after playing with it for a bit, selected [Intel] Partition Table and [Analyse]. The program said "Partition sector doesn't have the endmark 0xAA55.". What does this mean? (Thanks for your help so far though, here on the forums and by having made the program itself.)

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests