Need Proper Mac Recovery FS -6.x or 7-WIP

How to use TestDisk to recover lost partition
Post Reply
Message
Author
unimatrix725
Posts: 2
Joined: 16 Sep 2014, 09:23

Need Proper Mac Recovery FS -6.x or 7-WIP

#1 Post by unimatrix725 » 01 Oct 2014, 15:50

I have ran several scans. I have used 6.11.3 & 6.14 & 7.0-WIP. I have a good idea of what partitions need recovering. Thanks to testdisk telling me the parition size at the bottom when highlighting. Everytime I try to preview a HFS or HFS+ Partition, I am told FS support not enabled during compilation. I have downloaded the Mac Intel Specific versions. I tried to compile and failed, in both Linux and OS X. Compiling is too complicated for me in regards to testdisk. There are broken, missing or moved dependencies, not important. I tried Linux with HFS support installed and it doesn't work either. I am confused as to why this software is available for different platforms, yet has no proper preview support for specified version. I can preview the EFI fs just fine, which isn't truly used on Mac. Didn't try to preview the NTFS (Not real Important), the BackUp drive partition is rather important. I will scream from the rooftops DO NOT BUY A Toshiba Laptop form factor drive! I have 2 that are getting bad sectors both 1TB drives. The PS3 cant handle bad sectors period. Very light use, I might add.
So I am using a EFI based gpt style disk on Intel Mac Snow Leopard and Lion. This app is killer so far, it even sees some disk images and iso's and thinks they are partitions.

I am truly at the point of giving up. Since I am not able to properly preview the disks I am willing to write the partition table I think is correct. The tutorial says use pdisk, but I also read not to use it for Intel macs. So what should I use gdisk or something else? I can post the log but it is huge and will have to be a pastebin doc. It is 800k-1MB in size!
I will format the drive again before I use a file recovery app on it. I cant stand even the fancy mac apps, as they do not recover the file names and often do not have the proper extensions. I have seen similar complaints on the forum, yet there is no real solution.

What Happened:
Mac Mini needed to be upgraded and cleaned. I found a couple of bad sectors and thought it would be a good time to backup and format them out. I tried to delete some partitions at the end of the disk. Disk Utility Refused, So I said well let me format those foreign FS to Mac, then try removing or merging them all. I f*cking hate Apple right now. Been working on this for 3 wks. I clicked on the very last one hit Selected Erase and Mac HFS in drop down. Well Disk Utility Sh*t itself. Disk Utility decided to erase my whole drive! I assume it was a bug in Snow Leopard Disk Utility? I would say it was a little my fault for putting a linux distro on the disk. I had Mac, WinXP, BackUp, Recovery, Emergency, then all those needed Linux Parts. Never had any issues with this before. I would not be using the Mac if it were not for my desktop mobo needing to be sent in for repair. Everything I read tells me I will have issues with Asus...


TLDR: What disk utility should be used to write partitions on Intel GPT MAC?

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests