Problems to use a 2TB hard drive as a storage device

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Ander
Posts: 4
Joined: 29 Feb 2012, 22:43

Problems to use a 2TB hard drive as a storage device

#1 Post by Ander » 12 Oct 2014, 20:39

Hello

I need some help again, since I mess it up a quite a little bit... I explain: I have a 2TB hard disk which I was using as only and main disk in a desktop computer. It has (had) the next 4 partitions

Reserved partition: 100MB that that w7 creates normally with different purposes.
(Before no letter assigned, Now E)
c: System partition (Now F)
d: data partition 1 (Now G)
e: data partition 2 (Now H)

Well. A few days ago I installed a SSD in this computer. For such thing, I removed the 2TB hard drive and installed the OS in the SDD. Afterwards I connected the other disk. No problems up to here. The system booted with normality. All partitions appeared in the 2TB. Even the reserved partition. I decided format this last one from windows, since I didn’t want any problems having 2 booting partition. Still had no problem with this movement. However I found, that after proceeding with format, this partition had just 20-30MB free out of 100MB while apparently was empty. I left it there up today, when I had a fucking BRILLIANT idea. Lol:

My initial idea was to have “reserved partition” and “system partition” clean to fuse them to use that space for something else. Well. In order to fix the 20-30MB issue in the reserved partition I used DISKPART from command console and I used “clean” command. Well of course this was not a good idea at all. I thought it would apply only to the partition, but it seems to apply to the whole drive. Actually, later I thought that even when applied only to the partition, it might not have been a good idea either, since, as far as I thought later, there is one partition that may hold all the information about the other ones. And this one might have chances to be that partition –as in the system partition too. My knowledge about types of volume and partition is not wide. I know there are many kinds with many purposes.

At this point I took testdisk in order to recover the partition table. But the problem is that, even when it finds them, it doesn’t allow me to record them. At first it would have thrown an error –I have no screen of it. Now it sends another different every time I run testdisk, which tells me to play around with cylinders in the Geometry Menu, but I didn’t want to do it until knowing if this is necessary or it will just mess things up even more. I have thought of trying things using left/right arrow key to change the kind of partition manually to “primary” or “logical”...

-------------------------------------------------------------------------------------------
-------------------------------------------------------------------------------------------

Well I solved the problem while writing this by changing manually all partitions to “primary”, writing it, and rebooting... <-- solution for previous problem

Now I would need some help about how to proceed in order to clean “E:" to fuse it with “F:” which were “Reserved partition” and “System partition”, respectively. I have tried deleting partition using Windows disk manager, and creating a new volume with the unallocated 100MG. But still didn’t work:

Image

I’ve also tried doing the same and using “extend partition” in the System partition to add the 100MB unallocated space. But system warns about changing basic volume to dynamic volume and after accepting that it says that there isn’t enough space to proceed.

Any way to fuse both partitions without losing “System partition” files?

Thanks in advance for any advice and sorry about language mistakes.

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests