"Write Testdisk MBR Code to First Sector" partition lost

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 28 Oct 2014, 18:09

"Write Testdisk MBR Code to First Sector" partition lost

#1 Post by motu »

I tried to retrieve the single damaged partition of my 500 GB SATA HDD. It is connected as an external USB hard disk to a laptop running WinXP and Testdisk 6.14. Testdisk can find this HDD, the partition and with the right size. I accidentally pressed the "Write Testdisk MBR code to first sector" instead of "Analyse".

Now Testdrive can still find the HDD but the capacity becomes 2047 GB (instead of 465 GB) and cannot find any partition in it with "Analyse" (very slow and read error with every lba). Windows Device Manager can still find this drive, but it does not show up in Windows Disk Management.

What should I do next? Thanks.