HFS USB disk partition recovery

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 07 Nov 2014, 22:02

HFS USB disk partition recovery

#1 Post by changlinn »

Have a 2tb USB disk that a friend is trying to get some data off, it has one little ntfs partition and one big unallocated partition. It was their friends who has a MAC, they plugged it in to their PC and couldn't access it, they tried a friends MAC and nothing, the other disk they had from this friend worked with a HFS driver for windows. I ran testdisk, it came up with a deleted NTFS partition, but I knew it was a MAC so I went deeper, and found the below;

Code: Select all

Disk /dev/sdc - 2000 GB / 1863 GiB - CHS 243201 255 63

The harddisk (2000 GB / 1863 GiB) seems too small! (< 13425044 TB / 12210006 TiB)
Check the harddisk size: HD jumpers settings, BIOS detection...

The following partitions can't be recovered:
     Partition               Start        End    Size in sectors
>  Mac HFS                   381528 3907148479 3906766952
   Mac HFS                   381632 3907148583 3906766952
   Mac HFS                   381680 3907148631 3906766952
   Mac HFS                   381760 3907148711 3906766952
   Mac HFS                   381896 3907148847 3906766952
   Mac HFS                   382072 3907149023 3906766952
   Mac HFS                   382112 3907149063 3906766952
   Mac HFS                   382128 3907149079 3906766952
   Mac HFS                   382312 3907149263 3906766952
   Mac HFS                   382544 3907149495 3906766952
I can't use fdisk to create this partition as it is beyond the end of the disk. Any ideas?