USB Hard Drive File System Corruption?

Using TestDisk to repair the filesystem
Post Reply
Message
Author
zachary
Posts: 1
Joined: 09 Dec 2014, 04:04

USB Hard Drive File System Corruption?

#1 Post by zachary » 09 Dec 2014, 04:24

Hi!

I have a 1 TB WD My Passport for Mac that I use as extra storage for my Macbook Pro. Recently it's been totally screwed and I'm not sure why; I'm fairly certain the issue is a corrupt filesystem, but nothing I've tried can fix it. It happened that after booting my computer with it plugged in, it disappeared from Finder. It remained visible in Disk Utility and in WD's own software utility. No matter what I do (including OS X's Repair Disk, which returned an error), I can't get the disk to show up in Finder on this computer or an older Macbook. I guess physical damage is possible, as I'm not the only one that uses this computer (but I am the primary user).

So I figure no big deal, I've got a backup of all the really important files and try to reformat the drive in DiskUtility. This consistently returned an error "File System Formatter Failed," regardless of what kind of partition setup I tried to use: GUID, MBR, etc. I tried using a Gparted live CD as well, and though the drive shows up the whole thing is listed as "unallocated" and gives a vague error about file system damage.

Here is some information on this disk from diskutil:

Code: Select all

Zacharys-MacBook:-zachary$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *128.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh SSD           127.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
Zacharys-MacBook:~zachary$ diskutil info /dev/disk1
   Device Identifier:        disk1
   Device Node:              /dev/disk1
   Part of Whole:            disk1
   Device / Media Name:      WD My Passport 0748 Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      GUID_partition_scheme
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               1.0 TB (1000170586112 Bytes) (exactly 1953458176 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                Yes

   Whole:                    Yes
   Internal:                 No
   OS 9 Drivers:             No
   Low Level Format:         Not supported
As you can see, it doesn't appear to have a file system at all and returns that it has a GUID partition scheme.

In TestDisk, it shows up as "disk1 - 1000 GiB / 931 GiB." After selecting Analyze:

Code: Select all

Disk /dev/disk1 - 1000 GB / 931 GiB - 1953458176 sectors
Current partition structure:
     Partition                  Start        End    Size in sectors

 1 P EFI System                    40     409639     409600
I'm running a Quick Search now, but it's literally taking hours for some reason. It's a big drive, but it's been 2 hours and it's at 00%. It has given me these warnings:

Code: Select all

check_FAT: Unusual media descriptor (0xf0!=0xf8)
Warning: number of heads/cylinder mismatches 16 (FAT) != 1 (HD)
Warning: number of sectors per track mismatches 32 (FAT) != 1 (HD)
  EFI System                    40     409639     409600 [EFI]
Anybody got a clue how I could possibly make this thing work? I've already accepted that the data is gone, so that's not really a consideration. I'd just like to get the blasted thing reformatted if I can.

Sponsored links

DaenerysWD
Posts: 1
Joined: 08 Oct 2014, 08:28

Re: USB Hard Drive File System Corruption?

#2 Post by DaenerysWD » 09 Dec 2014, 09:41

Hi,

You're right, this could also be a hardware issue. I'd suggest you run a test to check your hard drive's health in order to make sure the drive is not failing:
Launch Disk Utility > Select the hard drive> “First Aid” tab> click on “Verify Disk”

A good idea would be to low level format the HDD, and then partition and format it. Keep in mind that this will completely erase the disk. Here you'll find some useful information regarding hard drives troubleshooting and low-level formatting on a Mac: http://support.apple.com/en-en/ht1641

Is your drive still under warranty? You could check here and if you can't get the drive to work, you could possibly contact WD Support in order to replace it: http://products.wdc.com/support/kb.ashx?id=fQM1Et
Here is some information on the RMA procedure: http://products.wdc.com/support/kb.ashx?id=yH4OG9

Let me know if you have any further questions :)

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests