Accidently changed GPT partition to NTFS

How to use TestDisk to recover lost partition
Post Reply
Message
Author
mstandifer
Posts: 2
Joined: 18 Dec 2014, 17:18

Accidently changed GPT partition to NTFS

#1 Post by mstandifer » 18 Dec 2014, 19:23

Contrary to the post title, I am not a complete idiot...really. I was recovering some files from a 1TB sata which had lost it's partition table.

I was copying the data over from the discovered files list and decided that it would be faster to just repair the partition table since all the data was intact. Well, instead of telling it to make the partition table GPT I told it to make it intel. As you can imagine, there is now no data.

I have tried going back to re-analyse the cylinders (it's doing that as we speak) but every cylinder read says
"Read error at xxxxx/xxx/xxx"

Can I undo this incorrect partition table naming and get it back to GPT?

No data has been overwritten on the disk, just the partition table.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3813
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Accidently changed GPT partition to NTFS

#2 Post by cgrenier » 19 Dec 2014, 08:04

I don't understand why you have these error messages.
When you are searching for your partition, have you selected the physical drive (correct choice) instead of a drive letter ?

mstandifer
Posts: 2
Joined: 18 Dec 2014, 17:18

Re: Accidently changed GPT partition to NTFS

#3 Post by mstandifer » 19 Dec 2014, 14:23

I don't understand why I have the error message either, which is why I am posting.

I know how to use this software but am unable to find in the documentation how to 'Undo' a partition change that goes bad.

Originally, I selected the disk (there is no drive letter because the partition does not exist). I did a quick scan and it found the lost partition marked with a 'D' for deleted. I changed the type to P and wrote the new partition table.

Well, something didn't take because it created 2 of the recovery partition, which I didn't need, so I went back in and found the one I was looking for and changed it to P but instead of making it a GPT partition (windows 8), I made it an Intel partition and wrote the table.

Once I did that, testdisk said nothing could be found. I held off on doing a deeper search because I want to see if there are steps I am missing that will allow me to Undo that Intel partition write. If not, I can maybe use Gdisk to write a GPT table on it but Id rather not.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests