After upgrade am unable to access files [SOLVED]

Using PhotoRec to recover lost data
Post Reply
Message
Author
frazelle09
Posts: 2
Joined: 19 Dec 2014, 20:39

After upgrade am unable to access files [SOLVED]

#1 Post by frazelle09 » 19 Dec 2014, 21:17

i'm running PCLinuxOS 64bit. i upgraded the same machine from the 32 bit version but evidently didn't see one of the options regarding my /home partition. i have installed new users on this partition but still cannot see the old folders and files.

The hard disk is 250 Gb with /, /swap and now /home on separate partitions: sda4, sda6 and sda7. sda7 is about 120 Gb total.

i ran testdisk once from a PCLinuxOS Live Install but at this point all i can find are the existing partitions and their folders an files.

i have a 500 Gb hd connect to the lappy by USB although it's only got about 180 Gb of space left.

A couple of questions now arise: Am i using the correct files recovery program for this task? If so, what other commands should i try to find these files? If not, what other program should i use... i've seen lots of references to photorec but it appears to be a program i'd have to but and for the Linux version they want $80 U.S.

Hopefully someone can give me a hand with this. Have a great afternoon! :)
Last edited by frazelle09 on 21 Dec 2014, 03:32, edited 1 time in total.

Sponsored links

frazelle09
Posts: 2
Joined: 19 Dec 2014, 20:39

Re: After upgrade am unable to access files [SOLVED]

#2 Post by frazelle09 » 21 Dec 2014, 03:31

It looks like photorec is available for free on from these developers.

i basically used an external hard drive, created two new partitions on it, copied the bad partition to one of them and ran photorec and saved the recovered files to the second partition.

Now for the hard part - figuring out what these 160,000 files contain!

Thanks for all your help and have a great evening! :)

User avatar
cgrenier
Site Admin
Posts: 3754
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: After upgrade am unable to access files [SOLVED]

#3 Post by cgrenier » 26 Dec 2014, 15:19

TestDisk & PhotoRec is free and open source software. Can you send me a private mail with the link where you have been asked to pay to access it ?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests