Lost Raid 6 array in VM guest running Ubuntu

How to use TestDisk to recover lost partition
Post Reply
Message
Author
cheechy
Posts: 1
Joined: 14 Jan 2015, 01:29

Lost Raid 6 array in VM guest running Ubuntu

#1 Post by cheechy » 14 Jan 2015, 01:39

Hi,

In need of some direction as I've pretty much lost hope of recovery.

Today I decided to use a tool called Clonezilla to clone my VMware based boot disc so that I could "tinker" with filesystem settings and not screw up my boot disc. So the cloning seem to complete ok, I swapped in the new cloned disc that ESX didn't really agree with so I swapped back. It though seems like the cloned copy modified RAID disks (completely separate disks to the boot) as when I put the original boot disc back in, my RAID 6 array has vanished in a puff of smoke.

So I've tried all sorts of simple checks to see if stuff is recoverable to no avail, being careful not to write anything to the RAID disks to at least try not to make things worse.

Having established the superblocks for all 4 RAID disks could not be found by the OS I've tried Testdisk also to no avail as it cant find any old versions. The server is currently running a deep analysis right now to see what is there - but at least for now Testdisk did see that a ext4 filesystem is there, even if it cant see anything.

So questions from me that I need some guidance on would be - if the testdisk client is installed on the Ubuntu OS and ran from within the client is it a VMFS or an EXT4 based filesystem? Seems to think its ext4 but I'm not sure!

Any other suggestions on what can be done to recover data?

Thanks :cry:

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests