LBA partition not shown after Analysis

How to use TestDisk to recover lost partition
Post Reply
Message
Author
LykanthricAura
Posts: 3
Joined: 02 Feb 2015, 07:19

LBA partition not shown after Analysis

#1 Post by LykanthricAura » 02 Feb 2015, 07:34

I lost 3 partition while using Windows Diskpart yesterday. Today I used TestDisk on Ubuntu 'Analyse' to see if they are still there.

I found them but here's the thing.

This the result I get of my UNDAMAGED harddrive. There are two partitions. And It clearly shows the Extended LBA thing.

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63

Partition Start End Size in sectors

1 * HPFS - NTFS 0 1 1 29371 254 63 471861117 [Data 02]
2 E extended LBA 29372 0 1 60800 254 63 504906885
5 L HPFS - NTFS 29372 1 1 58743 254 63 471861117 [Data 03]
6 L FAT16 >32M 58744 1 1 60800 254 63 33045642


The following is the Analysis of my HD which has partitions missing.

Disk /dev/sda - 1000 GB / 931 GiB - CHS 121601 255 63
Current partition structure:
Partition Start End Size in sectors

1 P HPFS - NTFS 0 32 33 2741 128 11 44040192 [Windows XP]
2 * Linux 2741 128 12 4112 0 61 22017101
3 E extended LBA 4112 0 62 121599 254 63 1887444659
5 L HPFS - NTFS 4112 1 1 33483 254 63 471861117 [Games]

*=Primary bootable P=Primary L=Logical E=Extended D=Deleted
>[Quick Search] [ Backup ]


AFTER Analysis is complete.


Disk /dev/sda - 1000 GB / 931 GiB - CHS 121601 255 63
Partition Start End Size in sectors
> HPFS - NTFS 0 1 1 3328 254 63 53480322
Linux 2741 128 12 4112 15 63 22018048
HPFS - NTFS 4112 1 1 33483 254 63 471861117 [Games]
* HPFS - NTFS 33484 1 1 62855 254 63 471861117 [Data 01]
P HPFS - NTFS 62856 1 1 92227 254 63 471861117 [Docs and Music]
P HPFS - NTFS 92228 1 1 121599 254 63 471861117 [Movies & Videos]

NTFS, blocksize=4096, 27 GB / 25 GiB

------------------------------------------------------------------------------------------------------------------------------------

And AFTER I press [Eneter]

Disk /dev/sda - 1000 GB / 931 GiB - CHS 121601 255 63

Partition Start End Size in sectors

1 * HPFS - NTFS 33484 1 1 62855 254 63 471861117 [Data 01]
2 P HPFS - NTFS 62856 1 1 92227 254 63 471861117 [Docs and Music]
3 P HPFS - NTFS 92228 1 1 121599 254 63 471861117 [Movies & Videos
]


As you can see. The LBA thing is missing. ALSO. the * marking the bootable partition gets set on the [Data 01] which is not how it's supposed to be. Is this normal. Should I go ahead and recover the partitions. Or...?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3458
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: LBA partition not shown after Analysis

#2 Post by cgrenier » 02 Feb 2015, 07:52

Use a more recent version of TestDisk.

LykanthricAura
Posts: 3
Joined: 02 Feb 2015, 07:19

Re: LBA partition not shown after Analysis

#3 Post by LykanthricAura » 02 Feb 2015, 07:56

I m running 6.14. Thats stable. Should I get the Beta?

LykanthricAura
Posts: 3
Joined: 02 Feb 2015, 07:19

Re: LBA partition not shown after Analysis

#4 Post by LykanthricAura » 02 Feb 2015, 08:29

Used v7 BETA. Same results.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests