Recovering accidentally formatted external drive

How to use TestDisk to recover lost partition
Post Reply
Message
Author
chemical
Posts: 1
Joined: 03 Feb 2015, 18:27

Recovering accidentally formatted external drive

#1 Post by chemical » 03 Feb 2015, 19:05

Hello to everybody!

I accidentaly formatted my external hard disk while creating a bootable startup drive using "Startup Disk Creator" in Kubuntu 14.04.

So my single 2TB etx4 partition vanished, to be replaced with a 2TB FAT32 partition.

I haven't used the drive so the data should still be there.

I tried the standard procedure with testdisk:
Selected disk --> Partition table type: Intel --> Quick Search --> Deeper search
but it found only the new FAT32 partition, plus some random HFS and FAT partitions that I believe are ISOs and virtual machine drives that were on the external hd.

I tried again the same procedure selecting:
Partition table type: None
In this case it actually found more partitions including and ext4 partition as big as the drive is, that I believe could be the one I lost.
When the search finished I tried to see the files on the partition using 'p', but to no avail.
At this point I think I pressed 'q' one time too much and returned to the main menù losing my Deeper scan data...

This is the log of the deeper scan: http://pastebin.com/rhFg1yqF

Code: Select all

recover_EXT2: "e2fsck -b 163840 -B 4096 device" may be needed
recover_EXT2: s_block_group_nr=5/14904, s_mnt_count=0/34, s_blocks_per_group=32768, s_inodes_per_group=8192
recover_EXT2: s_blocksize=4096
recover_EXT2: s_blocks_count 488376000
recover_EXT2: part_size 3907008000
     ext4                     0 254 62 243200 254 61 3907008000
     ext4 blocksize=4096 Large file Sparse superblock Backup superblock, 2000 GB / 1863 GiB
This, taken from the scan log, gave me the idea that something could be done, but I don't know what and how at this point.

I thought that recovering a simple format of an ext4 partition should have been possible.
Am I doing something wrong? Should I give up the idea of recovering the partition?

Thank you

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests