Quick Help with TestDisk

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 14 Mar 2015, 06:24

Quick Help with TestDisk

#1 Post by zenon »

Here my problem.. I have an external USB drive with 2 partitions. 1st is a small FAT32 partition(not encrypted). The second one is a VeraCrypt Partition(crypted). I can mount it with Veracrypt but the mounted drive shows nothing. If I right click on the mounted partition it says: X: Free space -> 0 bytes , Used space: 0 bytes (it doesn't show ANY file system but it should be exFat...)
There was a unplanned reboot and since then I can't access my my media..
I don't want to recover deleted files or something, I just want to make the drive accessible again.

Well I startet the tool and selected X:
Should I leave it to NONE?! I pressed enter..

Here I went 1 entry UP to ANALYSE..


What selection should I choose? TIA

Change Type? What does that mean?
List files?
Well, I hit ENTER..

I don't want to search for more partitions. I know there is just this one exfat... just need access.

What should I select?? It's a bit confusing and I don't want to make a mistake and make it worse... 30 mins ago my drive worked just fine. Please help! TIA!

User avatar
Site Admin
Posts: 5432
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Quick Help with TestDisk

#2 Post by cgrenier »

After selecting X:, partition type: None, select Advanced, Boot, List. Do you see your files ?
If no files are listed, run PhotoRec on this partition.