First post, weird (and desperate) problem -- long post

How to use TestDisk to recover lost partition
Post Reply
Message
Author
wymm1976
Posts: 2
Joined: 23 Mar 2015, 02:36

First post, weird (and desperate) problem -- long post

#1 Post by wymm1976 » 23 Mar 2015, 03:03

So here's the run down:

I'm using win7 pro x64

I've three disk, my system is installed on a 128gb kingston SSD, there's also two 3TB HDDs

In a nutshell, two of my 3TB harddrive have completely disappeared after using testdisk, undetectable from disk management, device manager, or even the BIOS. It was running the quickscan, and I wasn't use about the steps after that, so I closed the program to look online, and when I went back to try and scan again, the disk is no longer displayed...

It also disappeared from disk management...

anyway, here's the run down of what happened before (skip if you already know the problem from just that, this is what I did before I tried testdisk.

----

I've two 3TB HDD in my computer that's been recently mirrored using the windows disk management.
The one disk I have is about 75% full, and the other one was an older disk that's been .. well long story, in any case, it's been reformated.

I recently mirrored the disk (not even a week) to backup the data, since I've started to hear crunching noise from the computer indicating the declining health of the HDD.

Anyway, after having done so I noticed the in the disk management that it was resynching, and it was taking a long time, so I closed it and used my computer as I usually would, but then my games were running slowly, so I opened it up again and left it to run for a few hours. It ran and the progress got stuck at 24%, so I left my computer on for an another whole 24 hrs to see.

When I came back it was showing the resyching status to be 24% still, thinking it got stuck, I closed the program and restarted my computer. After that, I opened up the disk management again, and it was showing the disks were working okay. Yes, great.

But games were still running super slow...

So after trying to tolerate it for a few days, I opened up the Disk Managment again to check, lo and behold it was trying to resynch again. I quickly tried to unmirror the disk, but I won't stop since it was in the progress of synching.

So ... I deleted the mirror disk (disk2)... and suddenly both of my disks were gone back to unallocated....

---

After a quick search around the net, I found testdisk, and ran the program as prescribed by the step by step.
I stopped short of "write" since I wasn't sure at the time if it was the right option, so I left the program to check online again. But when I went back the disk was gone. just gone. Even after restarting my computer it was not registering in the BIOS.

Oh, quick note, after restarting, the computer got stuck on the BIOS information, it was trying to detect something from SATA2 (I presume where the disappeared HDD is connected to) for a long time before moving on, a couple minutes at least.

So one of my disk is gone for now, I started to test disk again to see what I can save from my, I presume, not-fully-synchronized other 3TB harddrive. And I followed through with the "write" step, but it said it was unable to, undetered, I tried to scan again, and it went into a different kind of scanning ..

Underneath Analyse cylinder, there's also a line that looks like this:
"Read error at 2949/254/63 <lba = 479605489>"

And already, the disk is no longer shown in the disk management, even as it is scanning

Actually, now that i remember, this happened to my other disk already, before it completely disappeared from testdisk too.

===

I am not going to lose both my drives, but it is taking a very very long time.

I will wait online for some response. Please Please help me out :cry:

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3501
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: First post, weird (and desperate) problem -- long post

#2 Post by cgrenier » 23 Mar 2015, 08:01

There are bad sectors. Try to clone each disk to a new empty one using gnu ddrescue.
http://www.cgsecurity.org/wiki/Damaged_Hard_Disk

wymm1976
Posts: 2
Joined: 23 Mar 2015, 02:36

Re: First post, weird (and desperate) problem -- long post

#3 Post by wymm1976 » 23 Mar 2015, 16:30

First, thanks for the reply.
I don't think bad sectors are the problem here, in any case, my two HDDs are now invisible to the computer, as in, not detectable as being even plugged in. I can't even see them in BIOS.

Just what did scanning my disks using testdisk do to them? Even if there were bad sectors they were working completely fine until I used testdisk to scan them..

before I can do anything now, first I'd have to be able to access the HDDs. Whatever testdisk scanning did, it made the disks invisible to my computer. Suggestion?

stumpyuk
Posts: 16
Joined: 19 Sep 2012, 11:41

Re: First post, weird (and desperate) problem -- long post

#4 Post by stumpyuk » 24 Mar 2015, 11:04

wymm1976 wrote:
since I've started to hear crunching noise from the computer indicating the declining health of the HDD.
Youch! There is symptomatic of a significant mechanical problem with the hard drive.
So after trying to tolerate it for a few days,


Ummm...not good. If you get a whiff of a mechanical problem you need to save your data to another device immediately. By continuing to use the device you are continually grinding through the fault, making it worse. Judging by the noise you describe, am guessing the arm of the read/write heads was failing and was no longer able to read all of the disk.

Testdisk does not do anything extraordinary to the disk, it simply reads the data, sector by sector, it won't write to the disk unless you tell it to. Testdisk didn't do anything to your disk beyond reading the data. However, using Testdisk on a disk with mechanical problems is risky as it will try and grind through the mechanical problems on your disk (it is not designed for detecting mechanical disk problems). It sounds like your disk was heading for complete failure and has now reached that stage following continual use after the problem became apparent.

Does your disk "spin up" i.e do any L.E.D lights light up, when you touch the disk can you detect slight vibration indicating the disk is spinning? If so, try updating your SATA/RAID/DISK drivers and see if they are now visible. You could also try getting a SATA/USB bridge, and attach the disk to a machine running Linux - I often got results this way where Windows failed. At any point, if you get the disk recognised DO NOT RUN TESTDISK against it - you must use something like ddrescue to recover as much data as possible, then run testdisk against the image file. If it doesn't spin up, you have suffered a complete mechanical failure and will need professional data recovery services if you haven't got your important data backed up.

Stumpy

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests