WD MyBookWorld Data Recovery

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Posts: 2
Joined: 03 Apr 2015, 23:08

WD MyBookWorld Data Recovery

#1 Post by GeoffatMM » 03 Apr 2015, 23:28

I have a dead disk that I have hooked to my ubuntu 14.04 box. Both ubuntu and windows see the drive but do not mount the partitions. Some partitions are empty but others are seen to be full, say they are healthy but do not recognise the file system so even a manual mount will not work. I do not know what file system is used.

Using testdisk I have written a new partition table (I think) but P does not let me see my files, instead I get a message that says;

"Support for this filesystem hasn't been enable (sic) during compilation"

Not sure what it means or what I have done wrong (if anything).

I will put up screen shots if someone can offer to help me? I am no expert so need to understand what is happening when I use testdisk. I am currently recovering the files using photorec but would prefer to get the directory structure visible to copy if at all possible.

Can anyone help?


Sponsored links

User avatar
Site Admin
Posts: 4722
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: WD MyBookWorld Data Recovery

#2 Post by cgrenier » 04 Apr 2015, 07:47

It will help if you post a copy of testdisk.log file content.

Posts: 2
Joined: 03 Apr 2015, 23:08

Re: WD MyBookWorld Data Recovery

#3 Post by GeoffatMM » 16 Apr 2015, 18:09

Thanks for your response and trying to help. In the end I tried then purchased UFS Explorer which located all the data and enabled me to transfer it to a second drive. Appreciate your support.


Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 1 guest