Compiling of current git version fails with QT error Topic is solved

How to use TestDisk to recover lost partition
Locked
Message
Author
camelcase
Posts: 2
Joined: 09 Jun 2015, 05:22

Compiling of current git version fails with QT error

#1 Post by camelcase » 10 Jun 2015, 16:07

Hello,

I'd like to compile the current git version of testdisk on a Debian Jessie system.

Unfortunately, configure throws following errors:

Code: Select all

./configure: line 8180: syntax error near unexpected token `QTGUI,'
./configure: line 8180: `  PKG_CHECK_MODULES(QTGUI, QtGui  >= 4.0.1,,use_qt=false)'
No matter if I call ./configure with or without --enable-qt=no

Seems that a qt-package is missing but I don't have a clue which one.

--
camelcase

Sponsored links

Tschorsch
Posts: 5
Joined: 26 Dec 2013, 21:54

Re: Compiling of current git version fails with QT error

#2 Post by Tschorsch » 16 Aug 2015, 13:36

Hi Guys,

I'm adding to this case, as I am facing the same problem. I'd like to compile from git, but get:
./configure: line 8197: syntax error near unexpected token `QTGUI,'
./configure: line 8197: ` PKG_CHECK_MODULES(QTGUI, QtGui >= 4.0.1,,use_qt=false)'
So I've tried
apt-get install qt4-default libqt4-core libqt4-dev

but the issue persists.

libqt4-designer is installed as well as "some other stuff", in particular libqtgui is installed:

Code: Select all

apt-cache policy libqtgui4
libqtgui4:
  Installed: 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
  Candidate: 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
  Version table:
 *** 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 0
        500 http://ftp.ie.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status
Could someone advise on what is required in terms of QT libraries et al. to compile testdisk?

Thanks,
T

Tschorsch
Posts: 5
Joined: 26 Dec 2013, 21:54

Re: Compiling of current git version fails with QT error

#3 Post by Tschorsch » 03 Sep 2015, 21:29

Hi - I am still hoping for a git pull that would fix the issue, but still I receive

Code: Select all

./configure: line 8197: syntax error near unexpected token `QTGUI,'
./configure: line 8197: `  PKG_CHECK_MODULES(QTGUI, QtGui  >= 4.0.1,,use_qt=false)'
Could I at least get some form of a hint, please?
Thanks

Tschorsch
Posts: 5
Joined: 26 Dec 2013, 21:54

Re: Compiling of current git version fails with QT error  Topic is solved

#4 Post by Tschorsch » 08 Oct 2015, 21:05

In case someone stumbles upon this - here is what did the trick for me:

i) make sure pkg-config is installed (following a hint Christophe gave, for which I am grateful!)
ii) rm -r testdisk/ (optional, I believe)
iii) mkdir testdisk (optional as well - I like stuff to be "clean")
iv) git clone http://git.cgsecurity.org/testdisk.git
v) cd testdisk && mkdir config
vi) autoreconf --install -W all -I config
vii) ./configure
viii) make
ix) cd /src && ./photorec => PhotoRec 7.1-WIP, Data Recovery Utility, May 2015

Locked

Who is online

Users browsing this forum: No registered users and 6 guests