Undelete file in a working FAT partition

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 2
Joined: 12 Jun 2015, 01:15

Undelete file in a working FAT partition

#1 Post by untel »


I tried the receipe in the following tutorial to undelete a file. The title seems to indicate it's to undelete a file in a FAT partition.

http://www.cgsecurity.org/wiki/TestDisk ... le_for_FAT

As I want to be sure I know how it works, before trying to recover my file, I tried to undelete files with a FAT USB Key and tried again with another FAT32 USB key. I get the same results everytime. it's not working.

Everything is OK till after I pick "advanced". Then it shows 4 lines :

4 * Sys=0D
2 * Netware 3.11+
1 * Sys=72
3 * Sys=79

No FAT partition appears. It's like testdisk is first looking for a deleted partition or bootable partition. Then I tried Analyse but again no partition can be found. In the information I got with analyse, I understood it's is looking for a Bootable partition.

I start testdisk.exe without anything else. Is my problem there ?

I must say that I tried to undelete the file with PhotoRec but it didn't work for my file. Could it be too large (around 500mb) ?

Thanks in advance J Guy

User avatar
Site Admin
Posts: 5432
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Undelete file in a working FAT partition

#2 Post by cgrenier »

Choose None for the partition table type.