Photorec finds partition, TestDisk doesn't

Using TestDisk to repair the filesystem
Post Reply
Message
Author
8bit
Posts: 9
Joined: 24 Jun 2015, 14:22

Photorec finds partition, TestDisk doesn't

#1 Post by 8bit » 24 Jun 2015, 15:06

I have an external 2TB Seagate GoFlex USB hard drive that has either failed hardware or a badly corrupted file system. I am trying to recover what I can using PhotoRec and TestDisk but even these tools are having problems.

The drive shows up in Win7 device manager and disk management - as "healthy" but "RAW". I tried to recover the partition using TestDisk - but it comes back "Partition: read error" and locks up. I can't seem to get TestDisk to read the drive.

However, when I select the drive in Photorec it says there is 1 partition; it's the length of the drive, and it's formatted as NTFS - i.e., it looks normal! I have been able to recover some files too - but after running several hours it says it has "10,000+ hours to go" so I shut it off. Upon examining the recovered files I found many of them were duplicates with different file names (some repeated hundreds of times). Other files were perfect.

So, what does all this mean? Why does Windows say it's "RAW" while PhotoRec says it "NTFS" and TestDisk can't read it at all? If the drive is mechanically bad (failed read heads, corrupt firmware, etc.) how was PhotoRec able to recover files?

I fear this drive is hopelessly scrambled but if there is still a chance to restore the file table what should I do next?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3461
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Photorec finds partition, TestDisk doesn't

#2 Post by cgrenier » 25 Jun 2015, 06:42

PhotoRec doesn't let the user choose the partition table type. Have you forced a type other than the one preselected by TestDisk ?

Otherwise it's better to select PhysicalDrive instead of drive letter like D:.

8bit
Posts: 9
Joined: 24 Jun 2015, 14:22

Re: Photorec finds partition, TestDisk doesn't

#3 Post by 8bit » 25 Jun 2015, 14:01

No, I have not tried any other file system. Testdisk shows NTFS in green but then says "read error" and locks up when I go to the next step (analysis).

I let Photorec run for 20 hours and was excited to see that it "recovered" 1084 files (and was only at 2%). However, when I opened the receiving drive to check the files I found hundreds of duplicates. I watched to see what was happening and, sure enough, kept seeing more copies of the same files being generated.

So, it seems, Photorec was stuck too.

Any suggestions at this point?

8bit
Posts: 9
Joined: 24 Jun 2015, 14:22

Re: Photorec finds partition, TestDisk doesn't

#4 Post by 8bit » 26 Jun 2015, 02:11

It appears my drive has bad sector(s) that once read into gets stuck in an endless loop reading the same data. At that point the drive behaves as if it's constantly busy and will not respond to any commands. Removing power resets the drive but then again only reads up to those failed sector(s).

Is there a way to "bust through" this barrier and continue recovery?

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests