Testdisk puts me in weird location when using "list files"

Using TestDisk to repair the filesystem
Post Reply
Message
Author
bloo
Posts: 2
Joined: 02 Jul 2015, 20:35

Testdisk puts me in weird location when using "list files"

#1 Post by bloo » 02 Jul 2015, 20:46

Hi. I'm trying to recover specific files from damaged partition. It seems that Testdisk would do it just fine - find partitions, list files then copy. But for some reason when I use list files option Testdisk puts me in some weird location on partition - rather than put me in most parent directory (it's C:\ so I would assume near Windows, Program Files etc.) it puts me in some small folder on Desktop and I can't go up (and it says it's '/'). Anyone have any idea why it's like this? Photorec seems to recover files just fine, so it seems that this small folder isn't only one on whole partition, but looking through 140000 photos (estimated on what I recovered so far) is no fun. Sorry for my English in advance, if anything is hard to understand just say ;)

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Testdisk puts me in weird location when using "list file

#2 Post by Fiona » 03 Jul 2015, 11:41

Did you use TestDisk 7.1WIP 32bit?
TestDisk 64bit should only be used on genuine 64bit machines like Itanium without 32bit environment (WoW64)) as some features are missing.
Also you should select disk instead of a drive?
But I've no info, that's why it's difficult to judge.
In case, you con copy and paste the content of your testdisk.log.
Did you try:
You can enter and leave a folder using the right and left arrow key on your keyboard.
If you select these 2 dots in the upper area of your testdisk display and pressing enter you will get one directory up until you get to your disk selection, where you can choose another disk or partition as your destination.
You can create a folder on a not affected healthy disk or partition in advance and enter it as your destination, where you'd like to copy your files too.

Fiona

bloo
Posts: 2
Joined: 02 Jul 2015, 20:35

Re: Testdisk puts me in weird location when using "list file

#3 Post by bloo » 03 Jul 2015, 12:42

Thanks for answer.
Yes I'm using 7.1-WIP 32 bit. And I'm selecting disk, not drive, my mistake. Here's testdisk.log. What may or may not be important I'm on Linux which was dual booted with Windows, now Windows partition is dead ("Actual VCN (0x2d45544143494649) of index buffer is different from expected VCN (0x5)." shows when trying to open it from Linux), but other NTFS I used for storage is working fine.
Tried moving with left and right arrow keys and using .. but nothing works. What I can see from files in this folder is that testdisk puts me in Downloads folder of Chrome, but this probably doesn't matter.

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Testdisk puts me in weird location when using "list file

#4 Post by Fiona » 04 Jul 2015, 08:19

Looks like that your file system is faulty/dirty.
Info:
ntfs_readdir failed for cluster 5: Input/output error

NTFS Volume is dirty.
ntfs_ucstoutf8: iconv_open failed
Can you run crystaldiskinfo?
http://crystalmark.info/download/index-e.html
You should use the potable version, because the installer (exe) contain adware Open Candy.
My recommentadion is to recover files as much as possible first.
You can copy available files using testdisk and running photorec to recover underlying files.
http://www.cgsecurity.org/wiki/PhotoRec_Step_By_Step
http://www.cgsecurity.org/wiki/PhotoRec
After backup/recovery you can have a try to repair your file system running chkdsk driveletter: /r.

Fiona

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests