External WD MyCloud disk size not correct

Using PhotoRec to recover lost data
Post Reply
Message
Author
swngdncr
Posts: 1
Joined: 17 Jul 2015, 06:53

External WD MyCloud disk size not correct

#1 Post by swngdncr » 17 Jul 2015, 07:02

I'm hoping someone can help me. I have a WD MyCloud drive that I am trying to recover files from. But, when I run the photorec program, it sees the drive, but the size is incorrect. I have the WD drive connect directly to the Mac via a Gigabit/Ethernet adapter. (I gather that connected on the network, it just doesn't show up as a drive that any of the recover programs seem to recognize).
Photorec does see the drive, I got that figured out and know which on it is, but it reports a 3TB drive as being 102GB. Is there anything that I can do to set up this WD drive so that Photorec can scan it and hopefully recover the files?
I was moving photo files to this drive and accidentally deleted a folder with 600 pictures in it. Totally unaware that there is no "undo" or "trash" on a network drive like this.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3501
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: External WD MyCloud disk size not correct

#2 Post by cgrenier » 17 Jul 2015, 20:11

If you want to recover files from your NAS, you have to use a version of PhotoRec compatible with the NAS processor and kernel version and run it from the NAS itself via SSH, or hook the disk from the NAS to a Linux computer. It's pretty technical, so you may have to contact a data recovery company.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests