NTFS partition MFT invalid

Using TestDisk to repair the filesystem
Post Reply
Message
Author
pusheax
Posts: 2
Joined: 14 Sep 2015, 12:08

NTFS partition MFT invalid

#1 Post by pusheax » 14 Sep 2015, 12:26

Hi, everyone!
Hoping someone will advance my understanding of NTFS and MFT in particular. Thanks for your help.

I have many partitions on my /dev/sda:

Code: Select all

NAME            MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda               8:0    0 465.8G  0 disk 
├─sda1            8:1    0   100M  0 part 
├─sda2            8:2    0   1.9G  0 part 
├─sda3            8:3    0    20G  0 part 
├─sda4            8:4    0  52.6G  0 part 
├─sda5            8:5    0 125.4G  0 part 
├─sda6            8:6    0 265.3G  0 part 
└─sda7            8:7    0   520M  0 part 
sdb               8:16   0 931.5G  0 disk 
└─sdb1            8:17   0 931.5G  0 part 
sdc               8:32   1   241M  0 disk 
└─sdc1            8:33   1 240.9M  0 part /root/iso
sr0              11:0    1 658.3M  0 rom  /run/archiso/bootmnt
loop0             7:0    0 286.6M  1 loop /run/archiso/sfs/airootfs
loop1             7:1    0    32G  1 loop 
└─arch_airootfs 254:0    0    32G  0 dm   /
loop2             7:2    0   256M  0 loop 
└─arch_airootfs 254:0    0    32G  0 dm   /
I use dual boot Arch/Windows7 with Grub2 in UEFI mode. I decided to give windows partition(sda4) more space because it grew. I used Acronis Disk Director 12. Turns out it was a bad idea. Now I know.

After resizing partition sda6 (to give more space to sda4) sda6 ended up Not Formatted (or raw if that's the same). Using ntfsfix I recovered PBS and copy PBS. Then I used testdisk to find MFT. Testdisk scanned sda6 (approx 30 minutes) and said nothing. Listing does not work. I booted windows recovery CD and tried to do chkdsk e: /f to recover my MFT - as I understand this is the only way. But chkdsk refused to work saying "unable to determine volume version and state chkdsk aborted".

photorec recovered some files. In fact I think allmost all of them. But they are effectively nameless so it's not that good. Why photorec not recovered names? I'm positive that names should be present.

Why chkdsk not working? Is there a way to assign volume version to partition?
Is my only remaining option to do quick format? I don't understand how quick format will restore MFT. Will it scan disk? Or it does not matter?

Regards,
Viacheslav

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3571
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: NTFS partition MFT invalid

#2 Post by cgrenier » 16 Sep 2015, 18:36

Run TestDisk, Advanced, select the partition, choose Boot, RebuildBS, List. If you see your files, choose Write and confirm.

pusheax
Posts: 2
Joined: 14 Sep 2015, 12:08

Re: NTFS partition MFT invalid

#3 Post by pusheax » 19 Sep 2015, 19:35

Hi, cgrenier!

Unfortunately that did not help with restoration of partition. testdisk managed to recover PBS and failed to find MFT. It's signature based search is nice but It gave me results without structure and names. Maybe that's the limitation of photorec when working with NTFS.

But I found a program "EaseUS Data Recovery", that managed to restore files with directory structure and names. It's commercial though.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests