Lots of partitions / no primary / hard to restore

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Jonas
Posts: 2
Joined: 27 Nov 2015, 12:08

Lots of partitions / no primary / hard to restore

#1 Post by Jonas » 27 Nov 2015, 13:25

Hello, dear community.

I have a Sony Vaio SVE1713C5E, Windows 8.1 64-bit, Intel i7

PRESTORY
- During the use of windows, a blue screen showed up -> Reboot.
- During Reboot, message "No Operating System found" showed up
- Reinstalling Windows didn't succeed as it said hard disk (or partition, I don't remember) would be locked
- MS DOS check said, hard disk is fine, showed 3 PARTITIONS of which the first one was lebelled "RAW" and the rest NFTS

TESTDISK
- Loading external Ubuntu and running Testdisk
- Size of hard disk labelled correctly
- EFI GPT partition map recognized -> chosen -> analyse
- showed 8 PARTITIONS -> Quick search
see here: http://www.bilder-hochladen.net/i/lv3e-1-6787.png
- 3 PARTITIONS were green highlighted, the rest were white. In these green partitions, there is not my hard disk data I was looking for and want to restore -> Deep scan
- See here: http://www.bilder-hochladen.net/i/lv3e-2-2473.png
- Deep scan found numerous partitions; I didn't "continue" at this point.
- See here: http://www.bilder-hochladen.net/i/lv3e-4-04ed.png
...and here: http://www.bilder-hochladen.net/i/lv3e-3-2bef.png

Here's the result of another rescue attempt: http://www.bilder-hochladen.net/i/lv3e-5-15bb.png
Still, everything is untouched. I didn't edit my disk yet; just checked responses from the program.

ISSUES/QUESTIONS
- Besides the numerous partitions, it looks like that there is no "primary partition" ( none is declared with 0 1 on top of the table).
- Assuming, that green highlighted means restoring, I do can set one partition with a big size (guessing that there's my data) by the left/right arrows. Is that effective? However, when I highlighted it, I can not check for the included files.
- I also tried the ADVANCED tools, but there was no perspective to improve something.
- One guy had the strategy to go to ADVANCED and declare his (in that case external) hard drive as " none partitioned media" and restore the boot sector. After, he could list his data and save them to another device. Is that a try worth?
- By trying things with TESTDISK, is all that reversible? Or can I mess up things more and irreversible when I choose the wrong strategy?

I'd thank you so much if you can help me.

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Lots of partitions / no primary / hard to restore

#2 Post by Fiona » 28 Nov 2015, 08:32

Did you already check your UEFI settings?
On SSD for example the security freeze lock?
Also security and legacy?
Do you have Intel Anti Theft istalled?
When Windows can't be installed, did you try to set your computer to CSM (compatibility support module?).
On UEFI and GPT your efi partition is your boot partition.
There is not always an active partition necessary.
Some info about UEFI boot and startup problems:
http://windowssecrets.com/top-story/how ... -problems/

Fiona

Jonas
Posts: 2
Joined: 27 Nov 2015, 12:08

Re: Lots of partitions / no primary / hard to restore

#3 Post by Jonas » 28 Nov 2015, 13:57

Thank you for the article. Indeed I also have the problem to boot externally. However, mostly it works with the Windows recovery and Ubuntu DVD.

Well yes, I did check the UEFI. I resetted it, and disabled security boot.
In my UEFI, there are very few settings to do. Basically, the boot order, security boot, UEFI or Legacy, and Intel Virtualization Technology (is disabled). No CSM option.
Pretty sure that Anti theft is not installed.
The hard drive is a common inernal one, so I don't think it is a SSD.
I don't know about other locking mechnisms.

When I checked my system in the recovery MS DOS, I used DISKPART to look if it is set as read only, but it is not.

Here's a picture of the response of DISKPART about my drive (on the right side, Status says "without errors"):
http://www.bilder-hochladen.net/i/lv3e-6-bcf2.jpg

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests