Incorrect endmark, invalid boot sector, HDD too small! Help.

How to use TestDisk to recover lost partition
Message
Author
Phase
Posts: 7
Joined: 28 Nov 2015, 15:00

Re: Incorrect endmark, invalid boot sector, HDD too small! H

#11 Post by Phase » 06 Dec 2015, 17:06

Vize wrote:Apologies for cutting in your conversation, but your description brought some old memories back to life.

I take it that the disk with problems is the 2nd disk: dev/sdb WDC WD10EADS.
This makes the disk part of the (unfortunately infamous) Western Digital WD Green Series (manufactured ~2009)

Is this disk part of an external backup drive like WD MyBook Essential connected via USB ?
If so, your problem is in all likelihood a damaged USB connector board.
Small fragile board but absolute essential to read data from disk and -that's why infamous- for 'security' reasons was paired with the disk, making it almost impossible to replace or bypass.
Not all hope would be lost though...just yet ;)
You might yet be the White Knight.
It is the second Disk.
It was a WD Green series from 2009.
It was also an external back-up drive. From memory it was created just before the whole "mybook" thing came out of WD, and as such isn't classed as a "MyBook", yet still looks the same when in its case.
I keep saying 'was' by the way because I pulled it out and SATA wired it direct to the motherboard, hoping to bypass the original issue. I do still have the external components though, including the USB board.

With what you say, that would explain the random software behaviour and why no programs can do anything with the disk, including windows, because I by-passed the USB board by SATA wiring it.
It would also explain why the Disk seemingly had software issues when the problem was seemingly caused by impacts to the hardware during flight (assumption based on time between working and not).

Ignoring the frankly terrible design choices by WD, you state not all hope is lost? why.
Do you have a potential solution? Can you help me?

Sponsored links

Vize
Posts: 2
Joined: 05 Dec 2015, 22:14

Re: Incorrect endmark, invalid boot sector, HDD too small! H

#12 Post by Vize » 08 Dec 2015, 14:47

I wish I could be your white knight, but I doubt it :D
all I can do is share some of my experience with WD Mybook Drives. But what saved me (or better say my data) twice, is unlikely to work in your case. But no harm in trying, eh ? ;-)

For my first 2 failing 'Mybooks' I was able to salvage the data using the testDisk tool, after that I smartened up just enough to have secondary backups - only this time using bare 'internal' drives in multi-bay drive enclosures.

As you have noticed yourself, without this USB connector board the data on disk is pretty much useless or even scrambled.
WDC's decision to make this board a mandatory, not circumventable part of the 'data-path' (meaning no direct SATA connection can be used to salvage data) is one thing, pairing a $5 crudely manufactured board with the disk to make it irreplaceable in the MyBook Series is another thing altogether.
This has caused a lot of unnecessary data losses under MyBook owners.
Not sure about your unit, but in later Models the USB connector board contained also certain parts of the drive logic for compatibility reasons (4k -> 512Byte Secors I believe it was)

Long story short, in my experience you need that board in place to have any chance at all for data recovery. A quick visual inspection for any obvious damage around the USB socket and corrosion is something one could do, I suppose ;-)

I have posted a brief step by step using the testdisk utility in the WDC forum back in 2011:
https://community.wd.com/t/mybook-essen ... ord/1976/3
No harm giving it a quick try, you won't have the timing issues due to the unlock utility, I suppose.

I would recommend to disconnect all other external drives for this first, not that by oversight you choose the wrong drive.
Use 'Append Log' as to not overwrite undo-information. Let me know if you need more details.

If it doesn't work, try updating (or reloading) the drive firmware and for good measure make sure you have the latest WD-drivers installed.
WD Universal Firmware Updater for Windows: http://download.wdc.com/fwupdater/Win/W ... pdater.zip
WD SES Driver (32-bit): http://download.wdc.com/smartware/WD_SE ... up_x86.zip
WD SES Driver (64-bit): http://download.wdc.com/smartware/WD_SE ... up_x64.zip
Data Lifeguard Diagnostic for Windows: http://download.wdc.com/windlg/WinDlg_v1_29.zip
last one is official diagnostic Tool of WDC.

all links as of today taken from http://support.wdc.com/downloads.aspx?DL&lang=en WD Software

No magical cure, sorry, just something that worked in my case.
Lastly, if all else fails, hope that your USB board is not yet paired but generic, you can buy replacements on ebay.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 0 guests