Recovering single partition on 4TB (GPT) external HDD

How to use TestDisk to recover lost partition
Post Reply
Message
Author
kkrena
Posts: 3
Joined: 06 Dec 2015, 07:15

Recovering single partition on 4TB (GPT) external HDD

#1 Post by kkrena » 06 Dec 2015, 08:25

Hello,

I was hoping I could get some guidance with recovering a partition from a 4TB external HDD (enclosure). My OS is Win7 and I'm fairly certain the drive was partitioned using GPT with an NTFS filesystem, but I'm not 100% sure. To the best of my knowledge, the drive only had a single partition--I was only using it to store media, but it's possible a reserved partition may have been created as well.

The problem started with me disconnecting the drive before it was safe to remove (foolishly) and afterwards the drive was showing up as RAW. I ran chkdsk /r first, which allowed me to see the correct drive name again, but could not access the drive. I manually set the permissions in the Security tab of the drive Properties, which let me access the drive but it was showing up as empty even though the usage was being shown as ~1.8TB.

After this I used testdisk 7.1-WIP (32b) to do a quick search--this found a single partition but with none of my old data. I did a deeper search, and this found many more partitions, most of which I think are corrupted. One note here is that for the deeper search I connected the drive directly to my internal SATA port to accelerate the search, and in doing so, Windows auto-chkdsk'ed the drive again as it was booting up. I'm not exactly sure what it did at this time...
testdisk0.PNG
testdisk0.PNG (35.58 KiB) Viewed 489 times
testdisk1.PNG
testdisk1.PNG (65.2 KiB) Viewed 489 times
I've attached the log here, it's quite long but most of it is lseek errors. I can't list the files the the Mac HFS partitions even though those seem most promising. I'm not sure why they're being listed as Mac HFS. The partitions I can list files for do not have anything I recognize.

Is there any chance to recover my data at this point or is this a lost cause? Thanks so much for your time in advance, I would appreciate any advice with my current situation.
Attachments
testdisk.zip
(27.12 KiB) Downloaded 42 times

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Recovering single partition on 4TB (GPT) external HDD

#2 Post by Fiona » 06 Dec 2015, 09:55

Chkdsk created a folder called found000.
Are there any chk-files inside?
Can you use testdisk and copy the found000-folder to a healthy disk or partition and check files using a utility mentionned below?
https://www.raymond.cc/blog/how-to-reco ... -scandisk/
Did you use TestDisk to run a Rebuild BS?
What's your current partition structure (GUID partition table?
Can you run TestDisk Analyse and upload another snapshot of your current partition structure (GUID partition table)?
Can you check your disk using CrystalDiskInfo?
http://crystalmark.info/download/index-e.html
Please use the portable version!

Fiona

kkrena
Posts: 3
Joined: 06 Dec 2015, 07:15

Re: Recovering single partition on 4TB (GPT) external HDD

#3 Post by kkrena » 06 Dec 2015, 19:04

Hi Fiona,

Thanks for the quick reply. I copied the found000 folder to my local drive but it seems to be empty.

I did use testdisk to Rebuild BS, but that was before Windows ran chkdsk on it automatically. It seems I can't even access the drive in question anymore, so perhaps I should run Rebuild BS again?

Here's what the partitions look like on the drive now:
testdisk2.PNG
testdisk2.PNG (16.57 KiB) Viewed 473 times
I'm not sure what the current partition structure is. Is it possible that chkdsk mistakenly assumed the drive to be something other than GPT?

Sorry I have to run for now, but I will use CrystalDiskInfo to do a check once I get back. Thanks again.

kkrena
Posts: 3
Joined: 06 Dec 2015, 07:15

Re: Recovering single partition on 4TB (GPT) external HDD

#4 Post by kkrena » 07 Dec 2015, 05:39

Hi Fiona,

Here is a snapshot of the disk in question using CrystalDiskInfo:
crystalmark0.PNG
crystalmark0.PNG (73.6 KiB) Viewed 467 times
Is this what you were looking for? I wasn't sure if there was an a chkdsk-style function I should call on the disk or if you just wanted to see the diagnostics. Let me know if there's any more info I can provide.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests