Cannot recover SD card

Using PhotoRec to recover lost data
Post Reply
Message
Author
jmer
Posts: 3
Joined: 24 Oct 2015, 03:08

Cannot recover SD card

#1 Post by jmer » 10 Jan 2016, 10:25

The other morning I found that my phone (a Samsung S6) suddenly stopped recognising my SD card - it says "unrecognised file system." I plugged it into an SD card reader but my PC also won't recognise it. Photorec and Testdisk both return absolutely nothing. If they recovered only small fragments I'd give up on it, but finding nothing at all sounds like there's some sort of filesystem error or encryption which isn't being recognised. Can anyone give me any tips on this?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3809
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Cannot recover SD card

#2 Post by cgrenier » 10 Jan 2016, 10:32

Is the card detected by PhotoRec ? Is the capacity correct ?
Run TestDisk, Adavnced, Image Creation. Compress the image.dd file (ie. zip). What is the resulting filesize ?

jmer
Posts: 3
Joined: 24 Oct 2015, 03:08

Re: Cannot recover SD card

#3 Post by jmer » 10 Jan 2016, 10:45

Card is detected, yes. The capacity looks right - 8gb - but I have no idea what the partition type should be for an SD card from an Android phone. Have tried a few, but it can't seem to find any file system with any of them - so can't do image creation.

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Cannot recover SD card

#4 Post by Fiona » 11 Jan 2016, 10:59

Phones on android, regularly formatting an external sd card to Fat32 LBA.
Can you run a diagnose and copy and paste the content of your testdisk.log?

Fiona

jmer
Posts: 3
Joined: 24 Oct 2015, 03:08

Re: Cannot recover SD card

#5 Post by jmer » 11 Jan 2016, 12:35

Sorry if I'm being slow here - I can't run a diagnose if I can't find a partition, can I? Anyway, I selected the SD card, , [Intel], [Analyse], [Quick search], [Deeper search], again found nothing, here's the log file.



Mon Jan 11 19:26:50 2016
Command line: TestDisk

TestDisk 7.1-WIP, Data Recovery Utility, January 2016
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows 7 (7601) SP1
Compiler: GCC 4.9, Cygwin32 2002.0
Compilation date: 2016-01-07T18:42:01
ext2fs lib: 1.42.8, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504, curses lib: ncurses 5.9
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=320072933376
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=8002732032
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=320072933376
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=8002732032
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=304237338624
filewin32_getfilesize(\\.\D:) GetFileSize err Incorrect function.

filewin32_setfilepointer(\\.\D:) SetFilePointer err Incorrect function.

Warning: can't get size for \\.\D:
filewin32_getfilesize(\\.\E:) GetFileSize err Incorrect function.

filewin32_setfilepointer(\\.\E:) SetFilePointer err Incorrect function.

Warning: can't get size for \\.\E:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\F:)=8002732032
Hard disk list
Disk /dev/sda - 320 GB / 298 GiB - CHS 38913 255 63, sector size=512 - WDC WD32 00BEVT-75A23, S/N:W -DXW12AAY05583, FW:01.0
Disk /dev/sdb - 8002 MB / 7632 MiB - CHS 972 255 63, sector size=512 - Mass Storage Device, FW:1.00

Partition table type default to Intel
Disk /dev/sdb - 8002 MB / 7632 MiB - Mass Storage Device
Partition table type: Intel

Analyse Disk /dev/sdb - 8002 MB / 7632 MiB - CHS 972 255 63
Current partition structure:

Partition sector doesn't have the endmark 0xAA55

search_part()
Disk /dev/sdb - 8002 MB / 7632 MiB - CHS 972 255 63
file_pread(5,1,buffer,15630337(972/240/38)) lseek err Invalid argument
file_pread(5,14,buffer,15630338(972/240/39)) lseek err Invalid argument
file_pread(5,3,buffer,15630352(972/240/53)) lseek err Invalid argument
file_pread(5,3,buffer,15630399(972/241/37)) lseek err Invalid argument
file_pread(5,8,buffer,15630415(972/241/53)) lseek err Invalid argument
file_pread(5,11,buffer,15630462(972/242/37)) lseek err Invalid argument
file_pread(5,2,buffer,15632384(973/18/6)) lseek err Invalid argument

Results

interface_write()

No partition found or selected for recovery

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest