Size destination drive larger than source.

Using PhotoRec to recover lost data
Post Reply
Message
Author
CrashHouse
Posts: 3
Joined: 17 Jan 2016, 12:56

Size destination drive larger than source.

#1 Post by CrashHouse » 17 Jan 2016, 13:23

First of all I'd like to thank Christophe Grenier and his crew for this incredible tool or tools. Being a multi-platform user I like the simplicity and effectivnes of these tools. For simple recovery it just works very well. But I encountered a problem that I'm not able to solve.

I have a Qnap NAS running the latest 4.2 QTS firmware, but after the release there appeared to be a bug that causes a structural message that the filesystem was not clean after a reboot. After several reboots and before the fix was available (QTS 4.2.1) my system broke down. I (and the technicians from Qnap) were not able to restore my system with the Qnap tools provided from them. So the system can be installed newly but than I loose all my files. Yes I didn't have a backup, cause I thought that wasn't necessary in case of a raid5 volume. Guess I was wrong.

Being a X86 NAS I got the idea to run the NAS using a Linux version. After several attempt the best config was running a Linux Live version of SystemRescueCD. I see the four (3Tb) discs (2.7) Tb and the different Volumes. I'm trying to use a external USB case running two 3Tb discs as JBOD (5.6 Tb).

Parted sees al discs and the 5.6Tb Volume, but when I'm trying to recover JPG files from one 2.7Tb Volume and choosing the 5.6 Tb usb Volume, Photorec says there is not enough space.

This is very curious, cause the destination volume is larger than the source volume. What am I doing wrong?

Sponsored links

CrashHouse
Posts: 3
Joined: 17 Jan 2016, 12:56

Re: Size destination drive larger than source.

#2 Post by CrashHouse » 18 Jan 2016, 08:59

Filtered it down to a permission issue regarding external media.

But next problem arrises

After I mounted the external harddisk (external usb device)

# mkdir /media/(name for external usb device)
# mount /dev/(external usb device) /media/(name for external usb device)
# chmod -R 777 /media/(name for external usb device)

Than I have read/write permissions and I'm able to make, alter and delete files and maps. But only until I run Photorec.
If I select (name for external usb device) I get the message that file of map recup_dir cannot be created at the destination. If I take a step back and go back to the destination through a file manager I still have read/write permissions, but the icon appears te be locked and I cannot add new maps files, or alter existing ones. So there is a difference in permissions. I'm a bit confused right now.... :roll:

User avatar
cgrenier
Site Admin
Posts: 3567
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Size destination drive larger than source.

#3 Post by cgrenier » 21 Jan 2016, 09:38

You may have to use as root

Code: Select all

chown -R username:groupname recup_dir.*

CrashHouse
Posts: 3
Joined: 17 Jan 2016, 12:56

Re: Size destination drive larger than source.

#4 Post by CrashHouse » 21 Jan 2016, 11:53

I will try later. For now I put the disks in the 4-bay enclosure running as RAID5. I attached the enclosure with a eSata cable and now I see all the disks with the same permissions. I'm doing a testrun with the buildin version off testdisk, but if it works will try the latest (beta) version.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests