Ok in TestDisk but RAW in Windows!

Using TestDisk to repair the filesystem
Message
Author
sbayes
Posts: 1
Joined: 30 May 2012, 07:25

Ok in TestDisk but RAW in Windows!

#1 Postby sbayes » 30 May 2012, 07:57

Hi

I've searched through the archives and found a few similar cases but would appreciate help on my problem and advice on solving it.

My situation:

A few days ago, my Windows 7 PC was shut down normally but when I turned it on again the next day, it could not find the partition containing the user data. Needless to say, I'm stuck. I've tried everything including System Restore, Startup Repair -- nothing works. CHKDSK found a couple of attribute record errors and corrected them. The first three stages of CHKDSK will pass without problems but it ALWAYS hangs at the USN Journal Verification stage.

Using a Linux-based Partition Recovery boot CD, I can see the partition and all the files and directories without issue but under Windows it is listed as RAW although healthy. Under TestDisk, I can also see all files and directories. I've taken a few screenshots attached below:

2012-05-30_131527.png
In Win 7, partition (drive D:) listed as RAW
2012-05-30_131527.png (22.74 KiB) Viewed 2489 times


2012-05-30_143821.png
TestDisk analysed partition without any problems
2012-05-30_143821.png (29.13 KiB) Viewed 2489 times


2012-05-30_143715.png
TestDisk able to see the files and directories
2012-05-30_143715.png (32.08 KiB) Viewed 2489 times


I have also run various partition recovery programs during testing and remember only one program reporting MFT Bitmap corruption.

Would appreciate expert advice on my best course of action. Why are Linux utilities and TestDisk finding the partition readable but Windows borks?

I would of course prefer to salvage and repair the partition/file system without formatting and going through the whole process of recovering data file by file.

Thanks.

Sponsored links

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: Ok in TestDisk but RAW in Windows!

#2 Postby remy » 07 Jun 2012, 12:56

Testdisk and linux doesn't access windows filesystem the same way windows does. The funny part of the story is that windows itself is not the better tool to access and repair it's own filesystem. :lol:

You may perhaps manage to repair your disk by using "Write" after the quicksearch that shows the previous result you mentionned. If not enough, go in advnaced menu and try to list after "repair BS". If it's still good, write also new BS. If this is still not enough, check with repair MFT if it's better, but sometimes it could be worse.

My advice : else you can copy files directly from testdisk (you can select all the files in one time and select then another destination) or better : mount your filesystem with linux and copy from it... Then reformat your partition under windows and re-copy the files. A bit longer, but :
1/ You will be sure that your partition is in good condition because it's a new one
2/ All your files will be defragmented after the copy.

It's a solution for the symptoms (partition in RAW) but be careful that you don't know the initial cause at this point : verify the disk and check if it has bad sectors.
J'ai pour habitude d'aller au bout de l'aide que j'apporte. Si vous pensez que je vous ai abandonné, et que je ne l'ai pas fait explicitement, c'est que votre message est enfoui avec d'autres. Relancez-moi (modérément) par mail.


Return to “Filesystem repair”

Who is online

Users browsing this forum: No registered users and 0 guests