Can't seem to get PhotoRec to save in the right directory

Using PhotoRec to recover lost data
Post Reply
Message
Author
nl22
Posts: 1
Joined: 04 Apr 2016, 19:34

Can't seem to get PhotoRec to save in the right directory

#1 Post by nl22 » 04 Apr 2016, 19:49

Hey all, new PhotoRec user here. Was hoping to get a hint of help on this before I give up on the repair indefinitely...

-> x64 Laptop
-> Drive appears to be locked from Windows' perspective.
-> chkdsk /f, sfc, dism cleanup, all fail
-> Running gparted-live-0.25.0-3-amd64 via CD-R
-> gparted notes the Windows partition as RAW
-> flags indicate inconsistent NTFS partition
-> used Check, operation fails in :01 second
-> error reports "failed to load $MFT: Input/Output error"
-> testdisk reports bad MFT and MFT mirror

So AFAIK the drive is unrecoverable. Next step was to recover files using PhotoRec, which lands me here.

I can't for the life of me figure out how to save the recovered files to my USB drive.

I initially ran it for 8 hours only for it to save the files on the root LIVE directory, which caused me to lose them when I turned it off. Stupid mistake.

-> sudo fdisk -l tells me the SanDisk drive is /dev/sdb and /dev/sdb1
-> I navigate to /dev/sdb and /dev/sdb1 in PhotoRec, but it doesn't allow me to open (aka press right arrow) on these directories
-> I navigate to dev / disk / by-id, select both SanDisk flash drives, it takes me back to the root screen
-> I tried manually mounting, already mounted.
-> I tried formatting as both NTFS and FAT32, same result
-> I tried two different flash drives, same result

For the love of god, what am I doing wrong? I'm not 100% versed in linux so if it's an issue on my end im going to flip shit. I just need to have PhotoRec select my USB drive to save the pictures/music to but it refuses to open the directory.


Thanks in advance

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3817
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Can't seem to get PhotoRec to save in the right director

#2 Post by cgrenier » 05 Apr 2016, 13:03

Check /mnt and /media directories. It's usually here that external disks (/partitions) are mounted.
You can use the "mount" command to learn where your partition are actually mounted.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests