WD Essentials MyBook - Can't recover partition

How to use TestDisk to recover lost partition
Post Reply
Message
Author
nitzans
Posts: 1
Joined: 25 Apr 2016, 23:50

WD Essentials MyBook - Can't recover partition

#1 Post by nitzans » 26 Apr 2016, 00:03

Hi everyone,
It might be a lost cause but I'm gonna try my luck anyways.
Apologizing in advance for the long story, but it is quite a story :(

I have a WD MyBook Essentials external hard drive. The external hard drive power-circuits gone very bad and i was unable to turn on the HDD through the external case.
Therefore, I decided to just go ahead and connect it to my PC directly without the external case.
It's important to note - the HDD itself is 100% okay. There was absolutely no issue with it. The only issue was the power-connector mechanism.

So I connected the HDD directly with the Sata cable innocently, without knowing that the USB-to-Sata chip additionally encrypts the data (without letting anyone know or the ability to control this encryption).
Windows popped up a window and because I'm an idiot I pressed okay - This was the "Initialize" window. So windows initialized the disk but saw it as RAW.
At least I was smart enough not to format it afterwards.

Understanding that something went wrong, but still not knowing at that time about the encryption, I booted up a rescue-linux with the HDD attached and tried to fix and tweak the boot sectors. Nothing helped (obviously since it was encrypted).

Afterwards I learned of the encryption so I tried to tweak the chip back into work with a limited success - I can make it work, but when it turns off I need to disconnect it entirely from everything for a few hours for the electricity to discharge.
So I connected it back with the USB chip and ran testdisk analyze with deepscan.

Unfortunately there was no magic recovery going on, got the following messages:
The harddisk seems too small!
The following partition can't be recovered.
(I'm attaching the log in the next post).

I'm certain that non of my data is actually damaged and only the bootsectors/partition table headers might have got nuked.
What is the best move I can do right now?

Thanks everyone so much,
Nitzan.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3619
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: WD Essentials MyBook - Can't recover partition

#2 Post by cgrenier » 26 Apr 2016, 06:24

If the partition is listed as RAW by Windows, go in the Advanced menu, choose Boot, RebuildBS, List. If you can see your files, choose Write, confirm, Quit and reboot.

If there is still a problem with the USB connector, you may want to clone the disk to a new empty one using gnu ddrescue. It's probably available on your rescue Linux.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests