Write access for this media is not available.

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 10 Jun 2016, 08:35

Write access for this media is not available.

#1 Post by tasca »

Hey guys,

Im trying to recover my exFAT partition from my Lacie RAID0 using a 2015 iMac. Here is what confused me.
TestDisk 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>

Disk /dev/rdisk2 - 6001 GB / 5589 GiB (RO)

Write access for this media is not available.
TestDisk won't be able to modify it.

- No partition from this disk must be mounted:
Open the Disk Utility (In Finder -> Application -> Utility folder)
and press Unmount button for each volume from this disk
- This media may be physically write-protected, check the jumpers.

>[ Continue ] Continue even if write access isn't available
[ Quit ] Return to disk selection
It said that write access for this media is not available. I enter my password when I opened the testdisk, which, I think, will give the program admin privilege.

I chose continue and analysis the disk, and find my exFAT partition, and I can copy the file from that partition. But when I chose WRITE option later on, it said "Partition: Write error", i tried three time with the same error.

Is there anything I can do to solve this? Need help! thx =P

Sponsored links

User avatar
Site Admin
Posts: 5307
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Write access for this media is not available.

#2 Post by cgrenier »

Mac OS X will not let you modify a disk if a partition is mounted.
Start a Terminal and run "mount". If a partition from this device is listed, use "umount /media/xxx" (adjust the command) to unmount the device and try again testdisk.