Can´t access SD Card

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 03 Jun 2012, 22:05

Can´t access SD Card

#1 Post by Hambach »


I have a 8 GB SD Card which I can´t access. When I start testdisk I get only the message "please wait". After several hours testdisk shows the partition table of my intenal hard drive, but nothing from the SD card. I have tested several card readers and I have tested a boot CD with testdisk and several other tools. In all cases the same result: No access to the SD card.

Has any body a bright idea what I can try to get access to the SD card and to recover the data ?


User avatar
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.

Re: Can´t access SD Card

#2 Post by remy »

Try a bit to bit copy with ddrescue under gnu/linux and then work on the copy. Unfortnately it will probably not work. Someone in this forum told that RecoverFab (Cie in Germany) has good results and was not too expensive.